@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ltq-vdsl-vr9
PKG_VERSION:=4.17.18.6
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_BASE_NAME:=drv_dsl_cpe_api
PKG_SOURCE:=$(PKG_BASE_NAME)_vrx-$(PKG_VERSION).tar.gz
@@ -55,17 +55,14 @@ CONFIGURE_ARGS += --enable-kernel-include="$(LINUX_DIR)/include" \
--enable-ifxos-include="-I$(STAGING_DIR)/usr/include/ifxos" \
--enable-driver-include="-I$(STAGING_DIR)/usr/include/vdsl" \
--enable-add-drv-cflags="-DMODULE -DINCLUDE_DSL_ATM_PTM_INTERFACE_SUPPORT" \
- --enable-adsl-led=no \
- --enable-adsl-mib=no \
- --enable-dsl-ceoc=no \
--enable-linux-26 \
--enable-kernelbuild="$(LINUX_DIR)" \
- --enable-debug-prints=no \
- --enable-dsl-pm-retx-counters \
- --enable-dsl-pm-retx-thresholds \
+ --enable-debug-prints=no
ARCH=mips
-CONFIGURE_ARGS += --enable-model=full
+CONFIGURE_ARGS += \
+ --enable-model=full \
+ --enable-dsl-ceoc=no
#CONFIGURE_ARGS += --enable-model=lite
#CONFIGURE_ARGS += --enable-model=footprint
#CONFIGURE_ARGS += --enable-model=typical
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ltq-vdsl-app
PKG_VERSION:=4.17.18.6
-PKG_RELEASE:=8
+PKG_RELEASE:=9
PKG_BASE_NAME:=dsl_cpe_control
PKG_SOURCE:=$(PKG_BASE_NAME)_vrx-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@OPENWRT
@@ -61,15 +61,12 @@ CONFIGURE_ARGS += \
--disable-dti \
--with-channels-per-line="1"
-#CONFIGURE_ARGS += --enable-model=full
+CONFIGURE_ARGS += \
+ --enable-model=full \
+ --enable-dsl-ceoc=no
#CONFIGURE_ARGS += --enable-model=lite
#CONFIGURE_ARGS += --enable-model=footprint
-CONFIGURE_ARGS += \
- --enable-model=typical \
- --enable-dsl-pm-showtime \
- --disable-dsl-ceoc \
- --enable-dsl-pm-retx-counters \
- --enable-dsl-pm-retx-thresholds
+#CONFIGURE_ARGS += --enable-model=typical
#CONFIGURE_ARGS += --enable-model=debug
define Package/ltq-vdsl-app/install
The userspace application now uses the model=full option to match the configuration of the kernel module. The source no longer contains SOAP support, which was the primary reason to build only typical instead of full before. This makes several CLI commands, which were already supported in the kernel module, available in the userspace application. For example, this includes bbsg which allows to get information about VDSL2 bands. Some previously applied build options were redundant. Disabling ADSL MIB support is unnecessary, as it only applies to Danube. ADSL LED support is no longer included in the source. ReTx counters are already included with model type full. This increases the size of the userspace application by approximately 15 kB (uncompressed). The kernel module does not change at all. Signed-off-by: Jan Hoffmann <jan@3e8.eu> --- If size is a concern, the option --enable-dsl-pm-optional-parameters=no could be added for both packages. Compared to the full build, this would remove support for several CLI commands (mostly related to PM thresholds and PM history stats), which were also previously unsupported in the application. Compared to the original build, the total size would then decrease by 18 kB (uncompressed, +4 kB for application, -22 kB for kernel module). package/kernel/lantiq/ltq-vdsl/Makefile | 13 +++++-------- package/network/config/ltq-vdsl-app/Makefile | 13 +++++-------- 2 files changed, 10 insertions(+), 16 deletions(-)