diff mbox series

target/x86: add grub2-bios-setup to DEFAULT_PACKAGES

Message ID 20210811095845.13052-1-fe@dev.tdt.de
State Accepted
Delegated to: Paul Spooren
Headers show
Series target/x86: add grub2-bios-setup to DEFAULT_PACKAGES | expand

Commit Message

Florian Eckert Aug. 11, 2021, 9:58 a.m. UTC
With the commit 5876d6a62fc0ae5799e7d9c896356f75c99a6f0a the command under
`/usr/sbin/grub-bios-setup` has been moved to its own package named
`grub-bios-setup`.

The script `81_upgrade_bootloader` under `/lib/preinit` is used by all
x86 targets to update the bootloader. The script is using the command
`grub-bios-setup` for this.

I get the following output at the first boot after the upgrade.
`/etc/preinit: line 9: /usr/sbin/grub-bios-setup: not found`.

To fix this, the DEFAULT_PACKAGES dependency is extended by the entry
`grub2-bios-setup` so that the missing command is installed again.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
---
 target/linux/x86/Makefile | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

Comments

Paul Spooren Sept. 19, 2022, 5:33 p.m. UTC | #1
> On 11. Aug 2021, at 11:58, Florian Eckert <fe@dev.tdt.de> wrote:
> 
> With the commit 5876d6a62fc0ae5799e7d9c896356f75c99a6f0a the command under
> `/usr/sbin/grub-bios-setup` has been moved to its own package named
> `grub-bios-setup`.
> 
> The script `81_upgrade_bootloader` under `/lib/preinit` is used by all
> x86 targets to update the bootloader. The script is using the command
> `grub-bios-setup` for this.
> 
> I get the following output at the first boot after the upgrade.
> `/etc/preinit: line 9: /usr/sbin/grub-bios-setup: not found`.
> 
> To fix this, the DEFAULT_PACKAGES dependency is extended by the entry
> `grub2-bios-setup` so that the missing command is installed again.
> 
> Signed-off-by: Florian Eckert <fe@dev.tdt.de>
> ---

Applied, thanks!

> target/linux/x86/Makefile | 5 ++++-
> 1 file changed, 4 insertions(+), 1 deletion(-)
> 
> diff --git a/target/linux/x86/Makefile b/target/linux/x86/Makefile
> index 0ab322d8bc..b1891de0ce 100644
> --- a/target/linux/x86/Makefile
> +++ b/target/linux/x86/Makefile
> @@ -17,7 +17,10 @@ KERNELNAME:=bzImage
> 
> include $(INCLUDE_DIR)/target.mk
> 
> -DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs kmod-button-hotplug
> +DEFAULT_PACKAGES += \
> +	partx-utils mkf2fs \
> +	e2fsprogs kmod-button-hotplug \
> +	grub2-bios-setup
> 
> $(eval $(call BuildTarget))
> 
> -- 
> 2.20.1
>
diff mbox series

Patch

diff --git a/target/linux/x86/Makefile b/target/linux/x86/Makefile
index 0ab322d8bc..b1891de0ce 100644
--- a/target/linux/x86/Makefile
+++ b/target/linux/x86/Makefile
@@ -17,7 +17,10 @@  KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs kmod-button-hotplug
+DEFAULT_PACKAGES += \
+	partx-utils mkf2fs \
+	e2fsprogs kmod-button-hotplug \
+	grub2-bios-setup
 
 $(eval $(call BuildTarget))