diff mbox series

fstools: libblkid-tiny: install header file to include dir

Message ID 20210802095709.3603235-1-daniel@dd-wrt.com
State Accepted
Delegated to: Daniel Golle
Headers show
Series fstools: libblkid-tiny: install header file to include dir | expand

Commit Message

Daniel Danzberger Aug. 2, 2021, 9:57 a.m. UTC
Hence libblkid-tiny is a shared lib, it makes sense to install it's
header to the system incldue/ dir for other applications to use it.

Signed-off-by: Daniel Danzberger <daniel@dd-wrt.com>
---
 CMakeLists.txt | 1 +
 1 file changed, 1 insertion(+)
diff mbox series

Patch

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 422f27d..9a87979 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,6 +38,7 @@  ADD_LIBRARY(blkid-tiny SHARED
 		libblkid-tiny/f2fs.c
 		)
 INSTALL(TARGETS blkid-tiny LIBRARY DESTINATION lib)
+INSTALL(FILES libblkid-tiny/libblkid-tiny.h DESTINATION include)
 
 ADD_LIBRARY(ubi-utils STATIC
 		libubi/libubi.c