diff mbox series

[21.02] Revert "netifd: update to the latest version"

Message ID 20210726150132.17317-1-ynezz@true.cz
State Deferred
Delegated to: Petr Štetiar
Headers show
Series [21.02] Revert "netifd: update to the latest version" | expand

Commit Message

Petr Štetiar July 26, 2021, 3:01 p.m. UTC
This reverts commit 089efd61e9a6cdc0ea39c184d37bc8ebbe03175c as it
breaks LAN network on at least mvebu/turris-omnia device.

Confirmed-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
Signed-off-by: Petr Štetiar <ynezz@true.cz>
---

I've discovered this today in the morning in my testbed where I perform daily
runtime tests of initramfs images on several devices, where images/tests for
snapshot and 21.02-SNAPSHOT failed on turris-omnia device.

1. https://gitlab.com/ynezz/openwrt-device-runtime-testing/-/pipelines/342708318

 package/network/config/netifd/Makefile | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Petr Štetiar July 26, 2021, 3:09 p.m. UTC | #1
Petr Štetiar <ynezz@true.cz> [2021-07-26 17:01:32]:

> This reverts commit 089efd61e9a6cdc0ea39c184d37bc8ebbe03175c as it
> breaks LAN network on at least mvebu/turris-omnia device.
> 
> Confirmed-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
> Signed-off-by: Petr Štetiar <ynezz@true.cz>
> ---
> 
> I've discovered this today in the morning in my testbed where I perform daily
> runtime tests of initramfs images on several devices, where images/tests for
> snapshot and 21.02-SNAPSHOT failed on turris-omnia device.

Sorry, forgot to provide more detials. The problem is with initialization of
LAN network, where the interface readiness is tested by following command:

 ifstatus lan | jsonfilter -qe "@.up"

then the LAN network availability is tested with simple `ping -c1 192.168.1.2`
command which timeouts. This is pristine image with no config changes, so the
device has 192.168.1.1/24 network config and the other end 192.168.1.2/24.

Console logs are available:

 snapshot https://gitlab.com/ynezz/openwrt-device-runtime-testing/-/jobs/1451323563/artifacts/file/console_turris-omnia-initramfs.txt
 21.02    https://gitlab.com/ynezz/openwrt-device-runtime-testing/-/jobs/1451222403/artifacts/file/console_turris-omnia-initramfs.txt

> 1. https://gitlab.com/ynezz/openwrt-device-runtime-testing/-/pipelines/342708318
> 
>  package/network/config/netifd/Makefile | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/package/network/config/netifd/Makefile b/package/network/config/netifd/Makefile
> index 35035519f95f..f80f07a4ff3a 100644
> --- a/package/network/config/netifd/Makefile
> +++ b/package/network/config/netifd/Makefile
> @@ -5,9 +5,9 @@ PKG_RELEASE:=1
>  
>  PKG_SOURCE_PROTO:=git
>  PKG_SOURCE_URL=$(PROJECT_GIT)/project/netifd.git
> -PKG_SOURCE_DATE:=2021-07-23
> -PKG_SOURCE_VERSION:=17e453bd68b41780b6564dafa8358efc29a00930
> -PKG_MIRROR_HASH:=06b6e10a71e3002fa03579846b97af29be9503d61486486c639dbfae423b398f
> +PKG_SOURCE_DATE:=2021-07-14
> +PKG_SOURCE_VERSION:=7f24a063475e1e2be4e0c516a5b62c3fae5ec542
> +PKG_MIRROR_HASH:=3fad25b8655e01e20f54b6c6decad6a660a34ab3ca2de97fe3c9b7db5aa485fe
>  PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
>  
>  PKG_LICENSE:=GPL-2.0
>
Felix Fietkau July 26, 2021, 6:44 p.m. UTC | #2
On 2021-07-26 17:09, Petr Štetiar wrote:
> Petr Štetiar <ynezz@true.cz> [2021-07-26 17:01:32]:
> 
>> This reverts commit 089efd61e9a6cdc0ea39c184d37bc8ebbe03175c as it
>> breaks LAN network on at least mvebu/turris-omnia device.
>> 
>> Confirmed-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
>> Signed-off-by: Petr Štetiar <ynezz@true.cz>
>> ---
>> 
>> I've discovered this today in the morning in my testbed where I perform daily
>> runtime tests of initramfs images on several devices, where images/tests for
>> snapshot and 21.02-SNAPSHOT failed on turris-omnia device.
> 
> Sorry, forgot to provide more detials. The problem is with initialization of
> LAN network, where the interface readiness is tested by following command:
> 
>  ifstatus lan | jsonfilter -qe "@.up"
> 
> then the LAN network availability is tested with simple `ping -c1 192.168.1.2`
> command which timeouts. This is pristine image with no config changes, so the
> device has 192.168.1.1/24 network config and the other end 192.168.1.2/24.
> 
> Console logs are available:
> 
>  snapshot https://gitlab.com/ynezz/openwrt-device-runtime-testing/-/jobs/1451323563/artifacts/file/console_turris-omnia-initramfs.txt
>  21.02    https://gitlab.com/ynezz/openwrt-device-runtime-testing/-/jobs/1451222403/artifacts/file/console_turris-omnia-initramfs.txt
Fixed the regression in master and 21.02, sorry about the mess.
For some reason, it did not trigger in my configurations...

- Felix
Nathan Lutchansky July 29, 2021, 9:52 p.m. UTC | #3
On Mon, 26 Jul 2021, Felix Fietkau wrote:
> Fixed the regression in master and 21.02, sorry about the mess.
> For some reason, it did not trigger in my configurations...

FWIW, the current 21.02 branch (55d9c020a1) fixes an outstanding issue for 
me with rc2/3 on my TP-Link EAP225-Outdoor v1 where the WLAN interface 
never got added to the right VLAN on br-lan on boot.  Pretty sure that was 
one of the recent netifd cherry-picks.  -Nathan
diff mbox series

Patch

diff --git a/package/network/config/netifd/Makefile b/package/network/config/netifd/Makefile
index 35035519f95f..f80f07a4ff3a 100644
--- a/package/network/config/netifd/Makefile
+++ b/package/network/config/netifd/Makefile
@@ -5,9 +5,9 @@  PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/netifd.git
-PKG_SOURCE_DATE:=2021-07-23
-PKG_SOURCE_VERSION:=17e453bd68b41780b6564dafa8358efc29a00930
-PKG_MIRROR_HASH:=06b6e10a71e3002fa03579846b97af29be9503d61486486c639dbfae423b398f
+PKG_SOURCE_DATE:=2021-07-14
+PKG_SOURCE_VERSION:=7f24a063475e1e2be4e0c516a5b62c3fae5ec542
+PKG_MIRROR_HASH:=3fad25b8655e01e20f54b6c6decad6a660a34ab3ca2de97fe3c9b7db5aa485fe
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
 PKG_LICENSE:=GPL-2.0