diff mbox series

[v2,1/2] zram-swap: clean up the makefile

Message ID 20210401133633.1307240-2-rsalvaterra@gmail.com
State Accepted
Delegated to: Hauke Mehrtens
Headers show
Series zram-swap improvements | expand

Commit Message

Rui Salvaterra April 1, 2021, 1:36 p.m. UTC
Break dependencies into separate lines, to improve the readability. Trim
trailing whitespace.

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
---
 package/system/zram-swap/Makefile | 12 +++++++++---
 1 file changed, 9 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/package/system/zram-swap/Makefile b/package/system/zram-swap/Makefile
index 18c6afee96..80f87fcdff 100644
--- a/package/system/zram-swap/Makefile
+++ b/package/system/zram-swap/Makefile
@@ -17,14 +17,20 @@  include $(INCLUDE_DIR)/package.mk
 define Package/zram-swap
   SECTION:=utils
   CATEGORY:=Base system
-  DEPENDS:=+kmod-zram +@BUSYBOX_CONFIG_MKSWAP +@BUSYBOX_CONFIG_SWAPON +@BUSYBOX_CONFIG_FEATURE_SWAPON_DISCARD +@BUSYBOX_CONFIG_FEATURE_SWAPON_PRI +@BUSYBOX_CONFIG_SWAPOFF
+  DEPENDS:= \
+	+@BUSYBOX_CONFIG_FEATURE_SWAPON_DISCARD \
+	+@BUSYBOX_CONFIG_FEATURE_SWAPON_PRI \
+	+@BUSYBOX_CONFIG_MKSWAP \
+	+@BUSYBOX_CONFIG_SWAPOFF \
+	+@BUSYBOX_CONFIG_SWAPON \
+	+kmod-zram
   TITLE:=ZRAM swap scripts
   PKGARCH:=all
 endef
 
 define Package/zram-swap/description
- A script to activate swaping on a compressed zram partition. This 
- could be used to increase the available memory, by using compressed 
+ A script to activate swaping on a compressed zram partition. This
+ could be used to increase the available memory, by using compressed
  memory.
 endef