@@ -17,14 +17,20 @@ include $(INCLUDE_DIR)/package.mk
define Package/zram-swap
SECTION:=utils
CATEGORY:=Base system
- DEPENDS:=+kmod-zram +@BUSYBOX_CONFIG_MKSWAP +@BUSYBOX_CONFIG_SWAPON +@BUSYBOX_CONFIG_FEATURE_SWAPON_DISCARD +@BUSYBOX_CONFIG_FEATURE_SWAPON_PRI +@BUSYBOX_CONFIG_SWAPOFF
+ DEPENDS:= \
+ +@BUSYBOX_CONFIG_FEATURE_SWAPON_DISCARD \
+ +@BUSYBOX_CONFIG_FEATURE_SWAPON_PRI \
+ +@BUSYBOX_CONFIG_MKSWAP \
+ +@BUSYBOX_CONFIG_SWAPOFF \
+ +@BUSYBOX_CONFIG_SWAPON \
+ +kmod-zram
TITLE:=ZRAM swap scripts
PKGARCH:=all
endef
define Package/zram-swap/description
- A script to activate swaping on a compressed zram partition. This
- could be used to increase the available memory, by using compressed
+ A script to activate swaping on a compressed zram partition. This
+ could be used to increase the available memory, by using compressed
memory.
endef
Break dependencies into separate lines, to improve the readability. Trim trailing whitespace. Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com> --- package/system/zram-swap/Makefile | 12 +++++++++--- 1 file changed, 9 insertions(+), 3 deletions(-)