@@ -26,8 +26,8 @@ $(eval $(call TestHostCommand,proper-umask, \
ifndef IB
$(eval $(call SetupHostCommand,gcc, \
Please install the GNU C Compiler (gcc) 6 or later, \
- $(CC) -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
- gcc -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
+ $(CC) -dumpversion | grep -E '^([6-9]\.?|1[0-9]\.?)', \
+ gcc -dumpversion | grep -E '^([6-9]\.?|1[0-9]\.?)', \
gcc --version | grep -E 'Apple.(LLVM|clang)' ))
$(eval $(call TestHostCommand,working-gcc, \
@@ -38,8 +38,8 @@ $(eval $(call TestHostCommand,working-gcc, \
$(eval $(call SetupHostCommand,g++, \
Please install the GNU C++ Compiler (g++) 6 or later, \
- $(CXX) -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
- g++ -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
+ $(CXX) -dumpversion | grep -E '^([6-9]\.?|1[0-9]\.?)', \
+ g++ -dumpversion | grep -E '^([6-9]\.?|1[0-9]\.?)', \
g++ --version | grep -E 'Apple.(LLVM|clang)' ))
$(eval $(call TestHostCommand,working-g++, \
Fedora 34 already uses GCC11. Reported-by: Marcin Juszkiewicz <marcin-openwrt@juszkiewicz.com.pl> Signed-off-by: Petr Štetiar <ynezz@true.cz> --- include/prereq-build.mk | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-)