diff mbox series

[v3,2/3] base-files: replace PKG_RELEASE with commitcount

Message ID 20210110092400.144356-2-mail@aparcar.org
State Superseded
Delegated to: Paul Spooren
Headers show
Series None | expand

Commit Message

Paul Spooren Jan. 10, 2021, 9:24 a.m. UTC
The newly added `commitcount` function does automatic versioning based
on the number of Git commits of a package. Replace *tedious to bump* and
*merge conflict causing* `PKG_RELEASE` and replace it with `commitcount`.

Signed-off-by: Paul Spooren <mail@aparcar.org>
---
 package/base-files/Makefile | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index f18f221129..52cf8a2b7b 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -12,7 +12,6 @@  include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=246
 PKG_FLAGS:=nonshared
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
@@ -40,7 +39,7 @@  define Package/base-files
   DEPENDS:=+netifd +libc +jsonfilter +SIGNED_PACKAGES:usign +SIGNED_PACKAGES:openwrt-keyring +NAND_SUPPORT:ubi-utils +fstools +fwtool
   TITLE:=Base filesystem for OpenWrt
   URL:=http://openwrt.org/
-  VERSION:=$(PKG_RELEASE)-$(REVISION)
+  VERSION:=$(call commitcount)-$(REVISION)
 endef
 
 define Package/base-files/conffiles