@@ -12,7 +12,6 @@ include $(INCLUDE_DIR)/version.mk
include $(INCLUDE_DIR)/feeds.mk
PKG_NAME:=base-files
-PKG_RELEASE:=245
PKG_FLAGS:=nonshared
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
@@ -40,7 +39,7 @@ define Package/base-files
DEPENDS:=+netifd +libc +jsonfilter +SIGNED_PACKAGES:usign +SIGNED_PACKAGES:openwrt-keyring +NAND_SUPPORT:ubi-utils +fstools +fwtool
TITLE:=Base filesystem for OpenWrt
URL:=http://openwrt.org/
- VERSION:=$(PKG_RELEASE)-$(REVISION)
+ VERSION:=$(call commitcount)-$(REVISION)
endef
define Package/base-files/conffiles
The newly added `commitcount` function does automatic versioning based on the number of Git commits of a package. Replace *tedious to bump* and *merge conflict causing* `PKG_RELEASE` and replace it with `commitcount`. Signed-off-by: Paul Spooren <mail@aparcar.org> --- package/base-files/Makefile | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-)