diff mbox series

wireguard-tools: bump to 1.0.20200827

Message ID 20200908163001.192718-1-Jason@zx2c4.com
State Changes Requested
Headers show
Series wireguard-tools: bump to 1.0.20200827 | expand

Commit Message

Jason A. Donenfeld Sept. 8, 2020, 4:30 p.m. UTC
* ipc: split into separate files per-platform

This is in preparation for FreeBSD support, which I had hoped to have this
release, but we're still waiting on some tooling fixes, so hopefully next
wg(8) will support that. Either way, the code base is now a lot more amenable
to adding more kernel platform support.

* man: wg-quick: use syncconf instead of addconf for strip example

Simple documentation fix.

* pubkey: isblank is a subset of isspace
* ctype: use non-locale-specific ctype.h

In addition to ensuring that isalpha() and such isn't locale-specific, we also
make these constant time, even though we're never distinguishing between bits
of a secret using them. From that perspective, though, this is markedly better
than the locale-specific table lookups in glibc, even though base64 characters
span two cache lines and valid private keys must hit both. This may be useful
for other projects too: https://git.zx2c4.com/wireguard-tools/tree/src/ctype.h
---
 package/network/utils/wireguard-tools/Makefile | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Hans Dedecker Sept. 9, 2020, 5:56 a.m. UTC | #1
Hi,

On Tue, Sep 8, 2020 at 6:30 PM Jason A. Donenfeld <Jason@zx2c4.com> wrote:
>
> * ipc: split into separate files per-platform
>
> This is in preparation for FreeBSD support, which I had hoped to have this
> release, but we're still waiting on some tooling fixes, so hopefully next
> wg(8) will support that. Either way, the code base is now a lot more amenable
> to adding more kernel platform support.
>
> * man: wg-quick: use syncconf instead of addconf for strip example
>
> Simple documentation fix.
>
> * pubkey: isblank is a subset of isspace
> * ctype: use non-locale-specific ctype.h
>
> In addition to ensuring that isalpha() and such isn't locale-specific, we also
> make these constant time, even though we're never distinguishing between bits
> of a secret using them. From that perspective, though, this is markedly better
> than the locale-specific table lookups in glibc, even though base64 characters
> span two cache lines and valid private keys must hit both. This may be useful
> for other projects too: https://git.zx2c4.com/wireguard-tools/tree/src/ctype.h

The patch is missing a SoB

Hans
> ---
>  package/network/utils/wireguard-tools/Makefile | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/package/network/utils/wireguard-tools/Makefile b/package/network/utils/wireguard-tools/Makefile
> index fb7c0b6..a5264a5 100644
> --- a/package/network/utils/wireguard-tools/Makefile
> +++ b/package/network/utils/wireguard-tools/Makefile
> @@ -11,12 +11,12 @@ include $(INCLUDE_DIR)/kernel.mk
>
>  PKG_NAME:=wireguard-tools
>
> -PKG_VERSION:=1.0.20200513
> +PKG_VERSION:=1.0.20200827
>  PKG_RELEASE:=2
>
>  PKG_SOURCE:=wireguard-tools-$(PKG_VERSION).tar.xz
>  PKG_SOURCE_URL:=https://git.zx2c4.com/wireguard-tools/snapshot/
> -PKG_HASH:=e73409a9fb8c90506db241d1e1a4e7372a60dbfa400e37f4ab2fd70a92ba495f
> +PKG_HASH:=51bc85e33a5b3cf353786ae64b0f1216d7a871447f058b6137f793eb0f53b7fd
>
>  PKG_LICENSE:=GPL-2.0
>  PKG_LICENSE_FILES:=COPYING
> --
> 2.28.0
>
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
Jason A. Donenfeld Sept. 9, 2020, 7:56 a.m. UTC | #2
On Tue, Sep 8, 2020 at 6:30 PM Jason A. Donenfeld <Jason@zx2c4.com> wrote:
>
> * ipc: split into separate files per-platform
>
> This is in preparation for FreeBSD support, which I had hoped to have this
> release, but we're still waiting on some tooling fixes, so hopefully next
> wg(8) will support that. Either way, the code base is now a lot more amenable
> to adding more kernel platform support.
>
> * man: wg-quick: use syncconf instead of addconf for strip example
>
> Simple documentation fix.
>
> * pubkey: isblank is a subset of isspace
> * ctype: use non-locale-specific ctype.h
>
> In addition to ensuring that isalpha() and such isn't locale-specific, we also
> make these constant time, even though we're never distinguishing between bits
> of a secret using them. From that perspective, though, this is markedly better
> than the locale-specific table lookups in glibc, even though base64 characters
> span two cache lines and valid private keys must hit both. This may be useful
> for other projects too: https://git.zx2c4.com/wireguard-tools/tree/src/ctype.h
> ---
>  package/network/utils/wireguard-tools/Makefile | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/package/network/utils/wireguard-tools/Makefile b/package/network/utils/wireguard-tools/Makefile
> index fb7c0b6..a5264a5 100644
> --- a/package/network/utils/wireguard-tools/Makefile
> +++ b/package/network/utils/wireguard-tools/Makefile
> @@ -11,12 +11,12 @@ include $(INCLUDE_DIR)/kernel.mk
>
>  PKG_NAME:=wireguard-tools
>
> -PKG_VERSION:=1.0.20200513
> +PKG_VERSION:=1.0.20200827
>  PKG_RELEASE:=2
>
>  PKG_SOURCE:=wireguard-tools-$(PKG_VERSION).tar.xz
>  PKG_SOURCE_URL:=https://git.zx2c4.com/wireguard-tools/snapshot/
> -PKG_HASH:=e73409a9fb8c90506db241d1e1a4e7372a60dbfa400e37f4ab2fd70a92ba495f
> +PKG_HASH:=51bc85e33a5b3cf353786ae64b0f1216d7a871447f058b6137f793eb0f53b7fd
>
>  PKG_LICENSE:=GPL-2.0
>  PKG_LICENSE_FILES:=COPYING
> --
> 2.28.0

Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
diff mbox series

Patch

diff --git a/package/network/utils/wireguard-tools/Makefile b/package/network/utils/wireguard-tools/Makefile
index fb7c0b6..a5264a5 100644
--- a/package/network/utils/wireguard-tools/Makefile
+++ b/package/network/utils/wireguard-tools/Makefile
@@ -11,12 +11,12 @@  include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=wireguard-tools
 
-PKG_VERSION:=1.0.20200513
+PKG_VERSION:=1.0.20200827
 PKG_RELEASE:=2
 
 PKG_SOURCE:=wireguard-tools-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://git.zx2c4.com/wireguard-tools/snapshot/
-PKG_HASH:=e73409a9fb8c90506db241d1e1a4e7372a60dbfa400e37f4ab2fd70a92ba495f
+PKG_HASH:=51bc85e33a5b3cf353786ae64b0f1216d7a871447f058b6137f793eb0f53b7fd
 
 PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=COPYING