diff mbox series

[OpenWrt-Devel] odhcpd: remove bogus IPKG_INSTROOT reference

Message ID 20200610162727.19344-1-ldir@darbyshire-bryant.me.uk
State Accepted
Headers show
Series [OpenWrt-Devel] odhcpd: remove bogus IPKG_INSTROOT reference | expand

Commit Message

Kevin 'ldir' Darbyshire-Bryant June 10, 2020, 4:27 p.m. UTC
IPKG_INSTROOT is only set under image builder and we won't be running
this script at build time either, so remove the reference before it gets
cargo-culted into other scripts.

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
---
 package/network/services/odhcpd/Makefile            | 2 +-
 package/network/services/odhcpd/files/odhcpd-update | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Hans Dedecker June 10, 2020, 7:58 p.m. UTC | #1
On Wed, Jun 10, 2020 at 6:27 PM Kevin Darbyshire-Bryant
<ldir@darbyshire-bryant.me.uk> wrote:
>
> IPKG_INSTROOT is only set under image builder and we won't be running
> this script at build time either, so remove the reference before it gets
> cargo-culted into other scripts.
>
> Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Acked-by: Hans Dedecker <dedeckeh@gmail.com>
> ---
>  package/network/services/odhcpd/Makefile            | 2 +-
>  package/network/services/odhcpd/files/odhcpd-update | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/package/network/services/odhcpd/Makefile b/package/network/services/odhcpd/Makefile
> index 6510ce6c80..07d7d7d673 100644
> --- a/package/network/services/odhcpd/Makefile
> +++ b/package/network/services/odhcpd/Makefile
> @@ -8,7 +8,7 @@
>  include $(TOPDIR)/rules.mk
>
>  PKG_NAME:=odhcpd
> -PKG_RELEASE:=3
> +PKG_RELEASE:=4
>
>  PKG_SOURCE_PROTO:=git
>  PKG_SOURCE_URL=$(PROJECT_GIT)/project/odhcpd.git
> diff --git a/package/network/services/odhcpd/files/odhcpd-update b/package/network/services/odhcpd/files/odhcpd-update
> index 9bc7abcc1c..c1814e00b0 100755
> --- a/package/network/services/odhcpd/files/odhcpd-update
> +++ b/package/network/services/odhcpd/files/odhcpd-update
> @@ -1,6 +1,6 @@
>  #!/bin/sh
>  # Make dnsmasq reread hostfile by sending SIGHUP signal
>
> -. $IPKG_INSTROOT/lib/functions/procd.sh
> +. /lib/functions/procd.sh
>
>  procd_send_signal dnsmasq
> --
> 2.24.3 (Apple Git-128)
>
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
Kevin 'ldir' Darbyshire-Bryant June 11, 2020, 2:46 p.m. UTC | #2
Merged into my staging tree.
Thank you!
diff mbox series

Patch

diff --git a/package/network/services/odhcpd/Makefile b/package/network/services/odhcpd/Makefile
index 6510ce6c80..07d7d7d673 100644
--- a/package/network/services/odhcpd/Makefile
+++ b/package/network/services/odhcpd/Makefile
@@ -8,7 +8,7 @@ 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcpd
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/odhcpd.git
diff --git a/package/network/services/odhcpd/files/odhcpd-update b/package/network/services/odhcpd/files/odhcpd-update
index 9bc7abcc1c..c1814e00b0 100755
--- a/package/network/services/odhcpd/files/odhcpd-update
+++ b/package/network/services/odhcpd/files/odhcpd-update
@@ -1,6 +1,6 @@ 
 #!/bin/sh
 # Make dnsmasq reread hostfile by sending SIGHUP signal
 
-. $IPKG_INSTROOT/lib/functions/procd.sh
+. /lib/functions/procd.sh
 
 procd_send_signal dnsmasq