diff mbox series

[OpenWrt-Devel] kernel: add gpio-it87

Message ID 20200429135406.30705-1-fe@dev.tdt.de
State Accepted
Delegated to: Petr Štetiar
Headers show
Series [OpenWrt-Devel] kernel: add gpio-it87 | expand

Commit Message

Florian Eckert April 29, 2020, 1:54 p.m. UTC
Since commit 910df3f06cc902ca2cb0ca8e963e9354c930df1a we have build in
on all X86/64 platforms the gpio-it87 driver.

Since this change I am getting the following error message on boot.
 > kern.err kernel: [    1.009416] gpio_it87: no device

I do not have this device on my system. To prevent the nonsensical
message and the loading of the module I have added this as a package, so
that it can be installed later or during image building.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
---
 package/kernel/linux/modules/other.mk | 18 ++++++++++++++++++
 target/linux/x86/64/config-4.19       |  2 +-
 target/linux/x86/64/config-5.4        |  2 +-
 3 files changed, 20 insertions(+), 2 deletions(-)

Comments

Philip Prindeville April 29, 2020, 4:55 p.m. UTC | #1
> On Apr 29, 2020, at 7:54 AM, Florian Eckert <fe@dev.tdt.de> wrote:
> 
> Since commit 910df3f06cc902ca2cb0ca8e963e9354c930df1a we have build in
> on all X86/64 platforms the gpio-it87 driver.
> 
> Since this change I am getting the following error message on boot.
>> kern.err kernel: [    1.009416] gpio_it87: no device
> 
> I do not have this device on my system. To prevent the nonsensical
> message and the loading of the module I have added this as a package, so
> that it can be installed later or during image building.
> 
> Signed-off-by: Florian Eckert <fe@dev.tdt.de>
> ---
> package/kernel/linux/modules/other.mk | 18 ++++++++++++++++++
> target/linux/x86/64/config-4.19       |  2 +-
> target/linux/x86/64/config-5.4        |  2 +-
> 3 files changed, 20 insertions(+), 2 deletions(-)
> 
> diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
> index 43709228f9..a3fb0577f5 100644
> --- a/package/kernel/linux/modules/other.mk
> +++ b/package/kernel/linux/modules/other.mk
> @@ -295,6 +295,24 @@ endef
> $(eval $(call KernelPackage,gpio-pcf857x))
> 
> 
> +define KernelPackage/gpio-it87
> +  SUBMENU:=$(OTHER_MENU)
> +  DEPENDS:=@GPIO_SUPPORT @TARGET_x86
> +  TITLE:=GPIO support for IT87xx Super I/O chips
> +  KCONFIG:=CONFIG_GPIO_IT87
> +  FILES:=$(LINUX_DIR)/drivers/gpio/gpio-it87.ko
> +  AUTOLOAD:=$(call AutoLoad,25,gpio-it87,1)
> +endef
> +
> +define KernelPackage/gpio-it87/description
> +  This driver is tested with ITE IT8728 and IT8732 Super I/O chips, and
> +  supports the IT8761E, IT8613, IT8620E, and IT8628E Super I/O chips as
> +  well.
> +endef
> +
> +$(eval $(call KernelPackage,gpio-it87))
> +
> +
> define KernelPackage/ppdev
>   SUBMENU:=$(OTHER_MENU)
>   TITLE:=Parallel port support
> diff --git a/target/linux/x86/64/config-4.19 b/target/linux/x86/64/config-4.19
> index 00ed09a4a6..eafae899dd 100644
> --- a/target/linux/x86/64/config-4.19
> +++ b/target/linux/x86/64/config-4.19
> @@ -218,7 +218,7 @@ CONFIG_GPIOLIB=y
> CONFIG_GPIOLIB_IRQCHIP=y
> CONFIG_GPIO_ACPI=y
> CONFIG_GPIO_ICH=y
> -CONFIG_GPIO_IT87=y
> +# CONFIG_GPIO_IT87 is not set
> CONFIG_GPIO_LYNXPOINT=y
> CONFIG_GPIO_SCH=y
> CONFIG_GPIO_SYSFS=y
> diff --git a/target/linux/x86/64/config-5.4 b/target/linux/x86/64/config-5.4
> index 899668f77e..2a58983957 100644
> --- a/target/linux/x86/64/config-5.4
> +++ b/target/linux/x86/64/config-5.4
> @@ -199,7 +199,7 @@ CONFIG_GPIOLIB=y
> CONFIG_GPIOLIB_IRQCHIP=y
> CONFIG_GPIO_ACPI=y
> CONFIG_GPIO_ICH=y
> -CONFIG_GPIO_IT87=y
> +# CONFIG_GPIO_IT87 is not set
> CONFIG_GPIO_LYNXPOINT=y
> CONFIG_GPIO_SCH=y
> CONFIG_GPIO_SYSFS=y
> -- 
> 2.20.1
> 


Reviewed-by: Philip Prindeville <philipp@redfish-solutions.com>
diff mbox series

Patch

diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 43709228f9..a3fb0577f5 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -295,6 +295,24 @@  endef
 $(eval $(call KernelPackage,gpio-pcf857x))
 
 
+define KernelPackage/gpio-it87
+  SUBMENU:=$(OTHER_MENU)
+  DEPENDS:=@GPIO_SUPPORT @TARGET_x86
+  TITLE:=GPIO support for IT87xx Super I/O chips
+  KCONFIG:=CONFIG_GPIO_IT87
+  FILES:=$(LINUX_DIR)/drivers/gpio/gpio-it87.ko
+  AUTOLOAD:=$(call AutoLoad,25,gpio-it87,1)
+endef
+
+define KernelPackage/gpio-it87/description
+  This driver is tested with ITE IT8728 and IT8732 Super I/O chips, and
+  supports the IT8761E, IT8613, IT8620E, and IT8628E Super I/O chips as
+  well.
+endef
+
+$(eval $(call KernelPackage,gpio-it87))
+
+
 define KernelPackage/ppdev
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Parallel port support
diff --git a/target/linux/x86/64/config-4.19 b/target/linux/x86/64/config-4.19
index 00ed09a4a6..eafae899dd 100644
--- a/target/linux/x86/64/config-4.19
+++ b/target/linux/x86/64/config-4.19
@@ -218,7 +218,7 @@  CONFIG_GPIOLIB=y
 CONFIG_GPIOLIB_IRQCHIP=y
 CONFIG_GPIO_ACPI=y
 CONFIG_GPIO_ICH=y
-CONFIG_GPIO_IT87=y
+# CONFIG_GPIO_IT87 is not set
 CONFIG_GPIO_LYNXPOINT=y
 CONFIG_GPIO_SCH=y
 CONFIG_GPIO_SYSFS=y
diff --git a/target/linux/x86/64/config-5.4 b/target/linux/x86/64/config-5.4
index 899668f77e..2a58983957 100644
--- a/target/linux/x86/64/config-5.4
+++ b/target/linux/x86/64/config-5.4
@@ -199,7 +199,7 @@  CONFIG_GPIOLIB=y
 CONFIG_GPIOLIB_IRQCHIP=y
 CONFIG_GPIO_ACPI=y
 CONFIG_GPIO_ICH=y
-CONFIG_GPIO_IT87=y
+# CONFIG_GPIO_IT87 is not set
 CONFIG_GPIO_LYNXPOINT=y
 CONFIG_GPIO_SCH=y
 CONFIG_GPIO_SYSFS=y