diff mbox series

[OpenWrt-Devel] wireguard: bump to 0.0.20190406

Message ID 20190406112409.11232-1-Jason@zx2c4.com
State Accepted
Headers show
Series [OpenWrt-Devel] wireguard: bump to 0.0.20190406 | expand

Commit Message

Jason A. Donenfeld April 6, 2019, 11:24 a.m. UTC
* allowedips: initialize list head when removing intermediate nodes

Fix for an important regression in removing allowed IPs from the last
snapshot. We have new test cases to catch these in the future as well.

* tools: warn if an AllowedIP has a nonzero host part

If you try to run `wg set wg0 peer ... allowed-ips 192.168.1.82/24`, wg(8)
will now print a warning. Even though we mask this automatically down to
192.168.1.0/24, usually when people specify it like this, it's a mistake.

* wg-quick: add 'strip' subcommand

The new strip subcommand prints the config file to stdout after stripping
it of all wg-quick-specific options. This enables tricks such as:
`wg addconf $DEV <(wg-quick strip $DEV)`.

* tools: avoid unneccessary next_peer assignments in sort_peers()

Small C optimization the compiler was probably already doing.

* peerlookup: rename from hashtables
* allowedips: do not use __always_inline
* device: use skb accessor functions where possible

Suggested tweaks from Dave Miller.

* blake2s: simplify
* blake2s: remove outlen parameter from final

The blake2s implementation has been simplified, since we don't use any of the
fancy tree hashing parameters or the like. We also no longer separate the
output length at initialization time from the output length at finalization
time.

* global: the _bh variety of rcu helpers have been unified
* compat: nf_nat_core.h was removed upstream
* compat: backport skb_mark_not_on_list

The usual assortment of compat fixes for Linux 5.1.

Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
---
 package/network/services/wireguard/Makefile | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Hans Dedecker April 6, 2019, 3:27 p.m. UTC | #1
On Sat, Apr 6, 2019 at 1:24 PM Jason A. Donenfeld <Jason@zx2c4.com> wrote:
>
> * allowedips: initialize list head when removing intermediate nodes
>
> Fix for an important regression in removing allowed IPs from the last
> snapshot. We have new test cases to catch these in the future as well.
>
> * tools: warn if an AllowedIP has a nonzero host part
>
> If you try to run `wg set wg0 peer ... allowed-ips 192.168.1.82/24`, wg(8)
> will now print a warning. Even though we mask this automatically down to
> 192.168.1.0/24, usually when people specify it like this, it's a mistake.
>
> * wg-quick: add 'strip' subcommand
>
> The new strip subcommand prints the config file to stdout after stripping
> it of all wg-quick-specific options. This enables tricks such as:
> `wg addconf $DEV <(wg-quick strip $DEV)`.
>
> * tools: avoid unneccessary next_peer assignments in sort_peers()
>
> Small C optimization the compiler was probably already doing.
>
> * peerlookup: rename from hashtables
> * allowedips: do not use __always_inline
> * device: use skb accessor functions where possible
>
> Suggested tweaks from Dave Miller.
>
> * blake2s: simplify
> * blake2s: remove outlen parameter from final
>
> The blake2s implementation has been simplified, since we don't use any of the
> fancy tree hashing parameters or the like. We also no longer separate the
> output length at initialization time from the output length at finalization
> time.
>
> * global: the _bh variety of rcu helpers have been unified
> * compat: nf_nat_core.h was removed upstream
> * compat: backport skb_mark_not_on_list
>
> The usual assortment of compat fixes for Linux 5.1.
>
> Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
Patch applied to master; thx

Hans
> ---
>  package/network/services/wireguard/Makefile | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/package/network/services/wireguard/Makefile b/package/network/services/wireguard/Makefile
> index aab3e59..c04762b 100644
> --- a/package/network/services/wireguard/Makefile
> +++ b/package/network/services/wireguard/Makefile
> @@ -11,12 +11,12 @@ include $(INCLUDE_DIR)/kernel.mk
>
>  PKG_NAME:=wireguard
>
> -PKG_VERSION:=0.0.20190227
> +PKG_VERSION:=0.0.20190406
>  PKG_RELEASE:=1
>
>  PKG_SOURCE:=WireGuard-$(PKG_VERSION).tar.xz
>  PKG_SOURCE_URL:=https://git.zx2c4.com/WireGuard/snapshot/
> -PKG_HASH:=fcdb26fd2692d9e1dee54d14418603c38fbb973a06ce89d08fbe45292ff37f79
> +PKG_HASH:=2f06f3adf70b95e74a7736a22dcf6e9ef623b311a15b7d55b5474e57c3d0415b
>
>  PKG_LICENSE:=GPL-2.0 Apache-2.0
>  PKG_LICENSE_FILES:=COPYING
> --
> 2.21.0
>
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/package/network/services/wireguard/Makefile b/package/network/services/wireguard/Makefile
index aab3e59..c04762b 100644
--- a/package/network/services/wireguard/Makefile
+++ b/package/network/services/wireguard/Makefile
@@ -11,12 +11,12 @@  include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=wireguard
 
-PKG_VERSION:=0.0.20190227
+PKG_VERSION:=0.0.20190406
 PKG_RELEASE:=1
 
 PKG_SOURCE:=WireGuard-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://git.zx2c4.com/WireGuard/snapshot/
-PKG_HASH:=fcdb26fd2692d9e1dee54d14418603c38fbb973a06ce89d08fbe45292ff37f79
+PKG_HASH:=2f06f3adf70b95e74a7736a22dcf6e9ef623b311a15b7d55b5474e57c3d0415b
 
 PKG_LICENSE:=GPL-2.0 Apache-2.0
 PKG_LICENSE_FILES:=COPYING