diff mbox series

[OpenWrt-Devel,3/5] uboot-mesongx: add new package

Message ID 20181019173707.22951-4-stijn@linux-ipv6.be
State Changes Requested
Delegated to: John Crispin
Headers show
Series mesongx: new target for AmLogic S9 SoCs | expand

Commit Message

Stijn Tintel Oct. 19, 2018, 5:37 p.m. UTC
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
---
 package/boot/uboot-mesongx/Makefile | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
 create mode 100644 package/boot/uboot-mesongx/Makefile
diff mbox series

Patch

diff --git a/package/boot/uboot-mesongx/Makefile b/package/boot/uboot-mesongx/Makefile
new file mode 100644
index 0000000000..4e64628148
--- /dev/null
+++ b/package/boot/uboot-mesongx/Makefile
@@ -0,0 +1,33 @@ 
+#
+# Copyright (C) 2017-2018 Stijn Tintel <stijn@linux-ipv6.be>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_VERSION:=2018.09
+PKG_RELEASE:=1
+
+PKG_HASH:=839bf23cfe8ce613a77e583a60375179d0ad324e92c82fbdd07bebf0fd142268
+
+include $(INCLUDE_DIR)/u-boot.mk
+include $(INCLUDE_DIR)/package.mk
+
+define U-Boot/Default
+  ARCH:=arm
+  BUILD_TARGET:=mesongx
+  HIDDEN:=1
+endef
+
+define U-Boot/odroid-c2
+  TITLE:=ODROID C2
+  BUILD_DEVICES:=odroid-c2
+endef
+
+UBOOT_TARGETS:= \
+	odroid-c2
+
+$(eval $(call BuildPackage/U-Boot))