diff mbox series

[OpenWrt-Devel] wireguard: bump to 0.0.20180910

Message ID 20180911005916.7426-1-Jason@zx2c4.com
State Accepted
Headers show
Series [OpenWrt-Devel] wireguard: bump to 0.0.20180910 | expand

Commit Message

Jason A. Donenfeld Sept. 11, 2018, 12:59 a.m. UTC
* curve25519: arm: do not modify sp directly
* compat: support neon.h on old kernels
* compat: arch-namespace certain includes
* compat: move simd.h from crypto to compat since it's going upstream

This fixes a decent amount of compat breakage and thumb2-mode breakage
introduced by our move to Zinc.

* crypto: use CRYPTOGAMS license

Rather than using code from OpenSSL, use code directly from AndyP.

* poly1305: rewrite self tests from scratch
* poly1305: switch to donna

This makes our C Poly1305 implementation a bit more intensely tested and also
faster, especially on 64-bit systems. It also sets the stage for moving to a
HACL* implementation when that's ready.

Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
---
 package/network/services/wireguard/Makefile | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Hans Dedecker Sept. 11, 2018, 9:38 a.m. UTC | #1
On Tue, Sep 11, 2018 at 3:00 AM Jason A. Donenfeld <Jason@zx2c4.com> wrote:
>
> * curve25519: arm: do not modify sp directly
> * compat: support neon.h on old kernels
> * compat: arch-namespace certain includes
> * compat: move simd.h from crypto to compat since it's going upstream
>
> This fixes a decent amount of compat breakage and thumb2-mode breakage
> introduced by our move to Zinc.
>
> * crypto: use CRYPTOGAMS license
>
> Rather than using code from OpenSSL, use code directly from AndyP.
>
> * poly1305: rewrite self tests from scratch
> * poly1305: switch to donna
>
> This makes our C Poly1305 implementation a bit more intensely tested and also
> faster, especially on 64-bit systems. It also sets the stage for moving to a
> HACL* implementation when that's ready.
>
> Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
Patch pushed to master
(https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=a54f492d0cf1f9bff1dd449961441e789c724995);thx

Hans
> ---
>  package/network/services/wireguard/Makefile | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/package/network/services/wireguard/Makefile b/package/network/services/wireguard/Makefile
> index c9608ec..ef00f80 100644
> --- a/package/network/services/wireguard/Makefile
> +++ b/package/network/services/wireguard/Makefile
> @@ -11,12 +11,12 @@ include $(INCLUDE_DIR)/kernel.mk
>
>  PKG_NAME:=wireguard
>
> -PKG_VERSION:=0.0.20180904
> +PKG_VERSION:=0.0.20180910
>  PKG_RELEASE:=1
>
>  PKG_SOURCE:=WireGuard-$(PKG_VERSION).tar.xz
>  PKG_SOURCE_URL:=https://git.zx2c4.com/WireGuard/snapshot/
> -PKG_HASH:=a38ead72994a7db7cda2d0085f410df1111b4728db050a519883eda8f3fe38f1
> +PKG_HASH:=43481ac82d4889491e1ae761d4ef10688410975cc861db5d2ac1845ac62eae39
>
>  PKG_LICENSE:=GPL-2.0 Apache-2.0
>  PKG_LICENSE_FILES:=COPYING
> --
> 2.18.0
>
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/package/network/services/wireguard/Makefile b/package/network/services/wireguard/Makefile
index c9608ec..ef00f80 100644
--- a/package/network/services/wireguard/Makefile
+++ b/package/network/services/wireguard/Makefile
@@ -11,12 +11,12 @@  include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=wireguard
 
-PKG_VERSION:=0.0.20180904
+PKG_VERSION:=0.0.20180910
 PKG_RELEASE:=1
 
 PKG_SOURCE:=WireGuard-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://git.zx2c4.com/WireGuard/snapshot/
-PKG_HASH:=a38ead72994a7db7cda2d0085f410df1111b4728db050a519883eda8f3fe38f1
+PKG_HASH:=43481ac82d4889491e1ae761d4ef10688410975cc861db5d2ac1845ac62eae39
 
 PKG_LICENSE:=GPL-2.0 Apache-2.0
 PKG_LICENSE_FILES:=COPYING