@@ -89,7 +89,8 @@ GEMINI_NAS_PACKAGES:=kmod-md-mod kmod-md-linear kmod-md-multipath \
define Device/dlink-dir-685
DEVICE_TITLE := D-Link DIR-685 Xtreme N Storage Router
DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) \
- kmod-switch-rtl8366rb swconfig
+ kmod-switch-rtl8366rb swconfig \
+ rt2800-pci
IMAGES += dir685-image
IMAGE/dir685-image := dir685-images
endef
@@ -119,7 +120,7 @@ TARGET_DEVICES += rut1xx
define Device/sq201
DEVICE_TITLE := ITian Square One SQ201
- DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) rt61-pci-firmware
+ DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) rt61-pci
endef
TARGET_DEVICES += sq201
The D-Link DIR-685 has a RealTek RT2880 mini-PCI card in a slot. Activate the appropriate kernel module. The Square One SQ201 has a Ralink RT61-based mini-PCI card. Activate the appropriate kernel modules. This fixes the previous error just activating the firmware: the kernel module will bring in the firmware it needs. Signed-off-by: Linus Walleij <linus.walleij@linaro.org> --- target/linux/gemini/image/Makefile | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-)