diff mbox series

[OpenWrt-Devel] kernel: make kmod-fbcon a built-in of kmod-fb

Message ID 20180330213915.21243-1-tomek_n@o2.pl
State Superseded
Delegated to: John Crispin
Headers show
Series [OpenWrt-Devel] kernel: make kmod-fbcon a built-in of kmod-fb | expand

Commit Message

Tomasz Maciej Nowak March 30, 2018, 9:39 p.m. UTC
As of commit 6104c37094 fbcon: Make fbcon a built-time depency for fbdev
framebuffer console is build in into framebuffer module and there's no
standalone fbcon module. Therfore drop the kmod-fbcon and enable console
in kmod-fb. The only targets which use these modules are imx6 and geode,
both are on kernel 4.14 so no fallback for other kernels is introduced.
Being at that this commit also fixes autoload of fbdev for x86.

Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
---
 package/kernel/linux/modules/video.mk | 50 ++++++++++-------------------------
 1 file changed, 14 insertions(+), 36 deletions(-)

Comments

Tomasz Maciej Nowak March 30, 2018, 10:17 p.m. UTC | #1
2018-03-30 23:39 GMT+02:00, Tomasz Maciej Nowak <tomek_n@o2.pl>:
> As of commit 6104c37094 fbcon: Make fbcon a built-time depency for fbdev
> framebuffer console is build in into framebuffer module and there's no
> standalone fbcon module. Therfore drop the kmod-fbcon and enable console
> in kmod-fb. The only targets which use these modules are imx6 and geode,
> both are on kernel 4.14 so no fallback for other kernels is introduced.
> Being at that this commit also fixes autoload of fbdev for x86.
>
> Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
> ---
>  package/kernel/linux/modules/video.mk | 50
> ++++++++++-------------------------
>  1 file changed, 14 insertions(+), 36 deletions(-)
>
> diff --git a/package/kernel/linux/modules/video.mk
> b/package/kernel/linux/modules/video.mk
> index f76618055f..3f46860f54 100644
> --- a/package/kernel/linux/modules/video.mk
> +++ b/package/kernel/linux/modules/video.mk
> @@ -56,34 +56,13 @@ $(eval $(call KernelPackage,backlight-pwm))
>
>  define KernelPackage/fb
>    SUBMENU:=$(VIDEO_MENU)
> -  TITLE:=Framebuffer support
> +  TITLE:=Framebuffer and framebuffer console support
>    DEPENDS:=@DISPLAY_SUPPORT
>    KCONFIG:= \
>  	CONFIG_FB \
>  	CONFIG_FB_MXS=n \
> -	CONFIG_FB_SM750=n
> -  FILES:=$(LINUX_DIR)/drivers/video/fbdev/core/fb.ko
> -  AUTOLOAD:=$(call AutoLoad,06,fb)
> -endef
> -
> -define KernelPackage/fb/description
> - Kernel support for framebuffers
> -endef
> -
> -define KernelPackage/fb/x86
> -  FILES+=$(LINUX_DIR)/arch/x86/video/fbdev.ko
> -  AUTOLOAD+=$(call AutoLoad,06,fbdev fb)
> -endef
> -
> -$(eval $(call KernelPackage,fb))
> -
> -
> -define KernelPackage/fbcon
> -  SUBMENU:=$(VIDEO_MENU)
> -  TITLE:=Framebuffer Console support
> -  DEPENDS:=+kmod-fb @!LINUX_4_14
> -  KCONFIG:= \
> -	CONFIG_FRAMEBUFFER_CONSOLE \
> +	CONFIG_FB_SM750=n \
> +	CONFIG_FRAMEBUFFER_CONSOLE=y \
>  	CONFIG_FRAMEBUFFER_CONSOLE_DETECT_PRIMARY=y \
>  	CONFIG_FRAMEBUFFER_CONSOLE_ROTATION=y \
>  	CONFIG_FONTS=y \
> @@ -102,23 +81,22 @@ define KernelPackage/fbcon
>  	CONFIG_CONSOLE_TRANSLATIONS=y \
>  	CONFIG_VT_CONSOLE=y \
>  	CONFIG_VT_HW_CONSOLE_BINDING=y
> -  FILES:= \
> -	$(LINUX_DIR)/drivers/video/console/bitblit.ko \
> -	$(LINUX_DIR)/drivers/video/console/softcursor.ko \
> -	$(LINUX_DIR)/drivers/video/console/fbcon.ko \
> -	$(LINUX_DIR)/drivers/video/console/fbcon_rotate.ko \
> -	$(LINUX_DIR)/drivers/video/console/fbcon_cw.ko \
> -	$(LINUX_DIR)/drivers/video/console/fbcon_ud.ko \
> -	$(LINUX_DIR)/drivers/video/console/fbcon_ccw.ko \
> +  FILES:=$(LINUX_DIR)/drivers/video/fbdev/core/fb.ko \
>  	$(LINUX_DIR)/lib/fonts/font.ko
> -  AUTOLOAD:=$(call AutoLoad,94,font softcursor tileblit fbcon_cw fbcon_ud
> fbcon_ccw fbcon_rotate bitblit fbcon)
> +  AUTOLOAD:=$(call AutoLoad,06,fb font)
>  endef
>
> -define KernelPackage/fbcon/description
> -  Kernel support for framebuffer console
> +define KernelPackage/fb/description
> + Kernel support for framebuffers and framebuffer console.
>  endef
>
> -$(eval $(call KernelPackage,fbcon))
> +define KernelPackage/fb/x86
> +  FILES+=$(LINUX_DIR)/arch/x86/video/fbdev.ko
> +  AUTOLOAD:=$(call AutoLoad,06,fbdev fb font)
> +endef
> +
> +$(eval $(call KernelPackage,fb))
> +
>
>  define KernelPackage/fb-cfb-fillrect
>    SUBMENU:=$(VIDEO_MENU)
> --
> 2.16.3
>
>

Please ignore this, there's second version with more suitable title:
[PATCH v2] kernel: merge kmod-fbcon with kmod-fb
diff mbox series

Patch

diff --git a/package/kernel/linux/modules/video.mk b/package/kernel/linux/modules/video.mk
index f76618055f..3f46860f54 100644
--- a/package/kernel/linux/modules/video.mk
+++ b/package/kernel/linux/modules/video.mk
@@ -56,34 +56,13 @@  $(eval $(call KernelPackage,backlight-pwm))
 
 define KernelPackage/fb
   SUBMENU:=$(VIDEO_MENU)
-  TITLE:=Framebuffer support
+  TITLE:=Framebuffer and framebuffer console support
   DEPENDS:=@DISPLAY_SUPPORT
   KCONFIG:= \
 	CONFIG_FB \
 	CONFIG_FB_MXS=n \
-	CONFIG_FB_SM750=n
-  FILES:=$(LINUX_DIR)/drivers/video/fbdev/core/fb.ko
-  AUTOLOAD:=$(call AutoLoad,06,fb)
-endef
-
-define KernelPackage/fb/description
- Kernel support for framebuffers
-endef
-
-define KernelPackage/fb/x86
-  FILES+=$(LINUX_DIR)/arch/x86/video/fbdev.ko
-  AUTOLOAD+=$(call AutoLoad,06,fbdev fb)
-endef
-
-$(eval $(call KernelPackage,fb))
-
-
-define KernelPackage/fbcon
-  SUBMENU:=$(VIDEO_MENU)
-  TITLE:=Framebuffer Console support
-  DEPENDS:=+kmod-fb @!LINUX_4_14
-  KCONFIG:= \
-	CONFIG_FRAMEBUFFER_CONSOLE \
+	CONFIG_FB_SM750=n \
+	CONFIG_FRAMEBUFFER_CONSOLE=y \
 	CONFIG_FRAMEBUFFER_CONSOLE_DETECT_PRIMARY=y \
 	CONFIG_FRAMEBUFFER_CONSOLE_ROTATION=y \
 	CONFIG_FONTS=y \
@@ -102,23 +81,22 @@  define KernelPackage/fbcon
 	CONFIG_CONSOLE_TRANSLATIONS=y \
 	CONFIG_VT_CONSOLE=y \
 	CONFIG_VT_HW_CONSOLE_BINDING=y
-  FILES:= \
-	$(LINUX_DIR)/drivers/video/console/bitblit.ko \
-	$(LINUX_DIR)/drivers/video/console/softcursor.ko \
-	$(LINUX_DIR)/drivers/video/console/fbcon.ko \
-	$(LINUX_DIR)/drivers/video/console/fbcon_rotate.ko \
-	$(LINUX_DIR)/drivers/video/console/fbcon_cw.ko \
-	$(LINUX_DIR)/drivers/video/console/fbcon_ud.ko \
-	$(LINUX_DIR)/drivers/video/console/fbcon_ccw.ko \
+  FILES:=$(LINUX_DIR)/drivers/video/fbdev/core/fb.ko \
 	$(LINUX_DIR)/lib/fonts/font.ko
-  AUTOLOAD:=$(call AutoLoad,94,font softcursor tileblit fbcon_cw fbcon_ud fbcon_ccw fbcon_rotate bitblit fbcon)
+  AUTOLOAD:=$(call AutoLoad,06,fb font)
 endef
 
-define KernelPackage/fbcon/description
-  Kernel support for framebuffer console
+define KernelPackage/fb/description
+ Kernel support for framebuffers and framebuffer console.
 endef
 
-$(eval $(call KernelPackage,fbcon))
+define KernelPackage/fb/x86
+  FILES+=$(LINUX_DIR)/arch/x86/video/fbdev.ko
+  AUTOLOAD:=$(call AutoLoad,06,fbdev fb font)
+endef
+
+$(eval $(call KernelPackage,fb))
+
 
 define KernelPackage/fb-cfb-fillrect
   SUBMENU:=$(VIDEO_MENU)