diff mbox

[OpenWrt-Devel] target/mpc85xx: check for 'generic' subtarget for initramfs image file

Message ID 1456837535-4145-1-git-send-email-aardelean@riverbed.com
State Accepted
Headers show

Commit Message

Alexandru Ardelean March 1, 2016, 1:05 p.m. UTC
From: Alexandru Ardelean <ardeleanalex@gmail.com>

Copy 'cuImage.tl-wdr4900-v1-initramfs' only for the 'generic' subtarget.
This is a follow-up to:
 http://git.openwrt.org/?p=openwrt.git;a=commitdiff;h=b889fe55c1844aec2c03da28fecb03e958c21f18

We build our initramfs images more rarely, so it took a while
to catch this too.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
---
 target/linux/mpc85xx/image/Makefile | 2 ++
 1 file changed, 2 insertions(+)
diff mbox

Patch

diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index 3c3f100..25a9b07 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -32,7 +32,9 @@  endef
 
 define Image/BuildKernel/Initramfs
 	cp $(KDIR)/zImage-initramfs $(BIN_DIR)/$(IMG_PREFIX)-initramfs-zImage
+ifeq ($(SUBTARGET),generic)
 	cp $(KDIR)/cuImage.tl-wdr4900-v1-initramfs $(BIN_DIR)/$(IMG_PREFIX)-tl-wdr4900-v1-initramfs.uImage
+endif
 endef
 
 define Image/Build/TPLINK