diff mbox

[OpenWrt-Devel] include/image.mk: Add dtb-install build function

Message ID 1448966630-18520-1-git-send-email-ynezz@true.cz
State RFC
Headers show

Commit Message

Petr Štetiar Dec. 1, 2015, 10:43 a.m. UTC
Signed-off-by: Petr Štetiar <ynezz@true.cz>
---
 include/image.mk |    4 ++++
 1 file changed, 4 insertions(+)

Comments

Jonas Gorski Dec. 1, 2015, 11:03 a.m. UTC | #1
Hi,

On Tue, Dec 1, 2015 at 11:43 AM, Petr Štetiar <ynezz@true.cz> wrote:
> Signed-off-by: Petr Štetiar <ynezz@true.cz>

Please try to avoid empty commit logs.

Also you don't add any users of this, so why should need this?


Jonas
Petr Štetiar Dec. 1, 2015, 1:27 p.m. UTC | #2
Jonas Gorski <jogo@openwrt.org> [2015-12-01 12:03:10]:

Hi,

> Please try to avoid empty commit logs.

sorry, I've forget to add RFC prefix in the patch.

> Also you don't add any users of this, so why should need this?

I'm preparing v2 patch series[1] for Toradex Apalis SOM (imx6) where I would
like to use dtb-install in the following way:

	define Device/apalis
		PROFILES = Generic APALIS
		DEVICE_DTS := imx6q-apalis-ixora
		KERNEL += | dtb-install
	endef

1. https://github.com/ynezz/openwrt/commit/9bd24b157a71316bb10a04f876ec27d3bb6746ad#diff-c3ef9a6728455333a1808755a5e95f59R119

Thanks.

-- ynezz
diff mbox

Patch

diff --git a/include/image.mk b/include/image.mk
index fd5e3f4..362643c 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -433,6 +433,10 @@  define Build/sysupgrade-nand
 		$@
 endef
 
+define Build/dtb-install
+	cp $(DTS_DIR)/$(DEVICE_DTS).dtb $(BIN_DIR)/$(IMG_PREFIX)-$(DEVICE_DTS).dtb
+endef
+
 define Device/Init
   PROFILES := $(PROFILE)
   DEVICE_NAME := $(1)