diff mbox

[OpenWrt-Devel,1/2] kernel: when enable HIGHMEM use long jump

Message ID 1433472873-24798-1-git-send-email-fl.service@t-firefly.com
State Rejected
Headers show

Commit Message

wengbj June 5, 2015, 2:54 a.m. UTC
Signed-off-by: wengbj <fl.service@t-firefly.com>
---
 ...ing-long-jump-when-memory-more-then-256mb.patch |   19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
 create mode 100644 target/linux/ramips/patches-3.18/0112-using-long-jump-when-memory-more-then-256mb.patch
diff mbox

Patch

diff --git a/target/linux/ramips/patches-3.18/0112-using-long-jump-when-memory-more-then-256mb.patch b/target/linux/ramips/patches-3.18/0112-using-long-jump-when-memory-more-then-256mb.patch
new file mode 100644
index 0000000..5029356
--- /dev/null
+++ b/target/linux/ramips/patches-3.18/0112-using-long-jump-when-memory-more-then-256mb.patch
@@ -0,0 +1,19 @@ 
+Index: linux-3.18.14/arch/mips/Makefile
+===================================================================
+--- linux-3.18.14.orig/arch/mips/Makefile	2015-06-05 09:52:08.144682065 +0800
++++ linux-3.18.14/arch/mips/Makefile	2015-06-05 09:58:40.472673911 +0800
+@@ -94,9 +94,14 @@
+ KBUILD_AFLAGS_MODULE		+= -mlong-calls
+ KBUILD_CFLAGS_MODULE		+= -mlong-calls
+ else
++ifdef CONFIG_HIGHMEM
++KBUILD_AFLAGS_MODULE		+= -mlong-calls
++KBUILD_CFLAGS_MODULE		+= -mlong-calls
++else
+ KBUILD_AFLAGS_MODULE		+= -mno-long-calls
+ KBUILD_CFLAGS_MODULE		+= -mno-long-calls
+ endif
++endif
+ 
+ ifndef CONFIG_FUNCTION_TRACER
+ KBUILD_CFLAGS_KERNEL		+= -ffunction-sections -fdata-sections