diff mbox

[OpenWrt-Devel] lldpd: add option to disable custom TLVs

Message ID 1433336818-11018-1-git-send-email-ardeleanalex@gmail.com
State Accepted
Headers show

Commit Message

Alexandru Ardelean June 3, 2015, 1:06 p.m. UTC
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
---
 package/network/services/lldpd/Config.in | 5 +++++
 package/network/services/lldpd/Makefile  | 1 +
 2 files changed, 6 insertions(+)
diff mbox

Patch

diff --git a/package/network/services/lldpd/Config.in b/package/network/services/lldpd/Config.in
index 448506d..93d84e2 100644
--- a/package/network/services/lldpd/Config.in
+++ b/package/network/services/lldpd/Config.in
@@ -41,6 +41,11 @@  config LLDPD_WITH_DOT3
 	prompt "Enable Dot3 extension (PHY stuff)"
 	default y
 
+config LLDPD_WITH_CUSTOM
+	bool
+	prompt "Enable Custom TLVs"
+	default y
+
 config LLDPD_WITH_JSON
 	bool
 	prompt "Enable JSON output for the LLDP Command-Line Interface"
diff --git a/package/network/services/lldpd/Makefile b/package/network/services/lldpd/Makefile
index cccb9ba..81e4a8f 100644
--- a/package/network/services/lldpd/Makefile
+++ b/package/network/services/lldpd/Makefile
@@ -100,6 +100,7 @@  CONFIGURE_ARGS += \
 	$(if $(CONFIG_LLDPD_WITH_LLDPMED),,--disable-lldpmed) \
 	$(if $(CONFIG_LLDPD_WITH_DOT1),,--disable-dot1) \
 	$(if $(CONFIG_LLDPD_WITH_DOT3),,--disable-dot3) \
+	$(if $(CONFIG_LLDPD_WITH_CUSTOM),,--disable-custom) \
 	$(if $(CONFIG_LLDPD_WITH_SONMP),,--disable-sonmp) \
 	$(if $(CONFIG_LLDPD_WITH_JSON),--with-json=json-c,--with-json=no)