diff mbox

[OpenWrt-Devel,1/4] kernel: mips jump only works with memory less then 256mb. when enable HIGHMEM use long jump

Message ID 1430214960-23587-1-git-send-email-fl.service@t-firefly.com
State Superseded
Headers show

Commit Message

wengbj April 28, 2015, 9:55 a.m. UTC
Signed-off-by: wengbj <fl.service@t-firefly.com>
---
 .../patches-3.18/305-mips_module_reloc.patch       |    7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)
diff mbox

Patch

diff --git a/target/linux/generic/patches-3.18/305-mips_module_reloc.patch b/target/linux/generic/patches-3.18/305-mips_module_reloc.patch
index 41cf806..fd31f9f 100644
--- a/target/linux/generic/patches-3.18/305-mips_module_reloc.patch
+++ b/target/linux/generic/patches-3.18/305-mips_module_reloc.patch
@@ -1,6 +1,6 @@ 
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -90,8 +90,13 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
+@@ -90,8 +90,18 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
  cflags-y			+= -G 0 -mno-abicalls -fno-pic -pipe -mno-branch-likely
  cflags-y			+= -msoft-float
  LDFLAGS_vmlinux			+= -G 0 -static -n -nostdlib --gc-sections
@@ -8,9 +8,14 @@ 
  KBUILD_AFLAGS_MODULE		+= -mlong-calls
  KBUILD_CFLAGS_MODULE		+= -mlong-calls
 +else
++ifdef CONFIG_HIGHMEM
++KBUILD_AFLAGS_MODULE		+= -mlong-calls
++KBUILD_CFLAGS_MODULE		+= -mlong-calls
++else
 +KBUILD_AFLAGS_MODULE		+= -mno-long-calls
 +KBUILD_CFLAGS_MODULE		+= -mno-long-calls
 +endif
++endif
  
  ifndef CONFIG_FUNCTION_TRACER
  KBUILD_CFLAGS_KERNEL		+= -ffunction-sections -fdata-sections