mbox series

[0/7] lib: sbi: sse: fixes after review

Message ID 20240409100216.263256-1-cleger@rivosinc.com
Headers show
Series lib: sbi: sse: fixes after review | expand

Message

Clément Léger April 9, 2024, 10:02 a.m. UTC
This small series addresses a few comments from Samuel that were made
after the series was merged.

Clément Léger (7):
  lib: sbi: sse: fix typos, comments and spacing errors
  lib: sbi: sse: rename sse_hart_unlock() to sse_enabled_event_unlock()
  lib: sbi: sse: simplify 32bits overflow check
  lib: sbi: sse: remove superfluous sbi_list_empty() check
  lib: sbi: sse: call enable callback before sending IPI
  lib: sbi: sse: use PRV_S instead of hardcoded value for mode
  lib: sbi: sse: check handler entry to belong to supervisor mode

 include/sbi/sbi_ecall_interface.h | 24 +++++++-------
 lib/sbi/sbi_sse.c                 | 53 ++++++++++++++++---------------
 2 files changed, 40 insertions(+), 37 deletions(-)

Comments

Anup Patel May 7, 2024, 12:06 p.m. UTC | #1
On Tue, Apr 9, 2024 at 3:32 PM Clément Léger <cleger@rivosinc.com> wrote:
>
> This small series addresses a few comments from Samuel that were made
> after the series was merged.
>
> Clément Léger (7):
>   lib: sbi: sse: fix typos, comments and spacing errors
>   lib: sbi: sse: rename sse_hart_unlock() to sse_enabled_event_unlock()
>   lib: sbi: sse: simplify 32bits overflow check
>   lib: sbi: sse: remove superfluous sbi_list_empty() check
>   lib: sbi: sse: call enable callback before sending IPI
>   lib: sbi: sse: use PRV_S instead of hardcoded value for mode
>   lib: sbi: sse: check handler entry to belong to supervisor mode

Applied this series to the riscv/opensbi repo.

Thanks,
Anup

>
>  include/sbi/sbi_ecall_interface.h | 24 +++++++-------
>  lib/sbi/sbi_sse.c                 | 53 ++++++++++++++++---------------
>  2 files changed, 40 insertions(+), 37 deletions(-)
>
> --
> 2.43.0
>
>
> --
> opensbi mailing list
> opensbi@lists.infradead.org
> http://lists.infradead.org/mailman/listinfo/opensbi