Message ID | 20221101102916.440526-1-j.neuschaefer@gmx.net |
---|---|
State | New |
Headers | show |
Series | ARM: dts: nuvoton,wpcm450-supermicro-x9sci-ln4f: Add GPIO line names | expand |
On Tue, 1 Nov 2022 at 10:29, Jonathan Neuschäfer <j.neuschaefer@gmx.net> wrote: > > To make gpioinfo output more useful and enable gpiofind usage, add line > names for GPIOs where the function is known. > > This patch follows the naming convention defined for OpenBMC, as much as > possible: > > https://github.com/openbmc/docs/blob/master/designs/device-tree-gpio-naming.md > > Signed-off-by: Jonathan Neuschäfer <j.neuschaefer@gmx.net> Reviewed-by: Joel Stanley <joel@jms.id.au> > --- > .../nuvoton-wpcm450-supermicro-x9sci-ln4f.dts | 18 ++++++++++++++++++ > 1 file changed, 18 insertions(+) > > diff --git a/arch/arm/boot/dts/nuvoton-wpcm450-supermicro-x9sci-ln4f.dts b/arch/arm/boot/dts/nuvoton-wpcm450-supermicro-x9sci-ln4f.dts > index 26fed97f8ff4a..d4472ffdac928 100644 > --- a/arch/arm/boot/dts/nuvoton-wpcm450-supermicro-x9sci-ln4f.dts > +++ b/arch/arm/boot/dts/nuvoton-wpcm450-supermicro-x9sci-ln4f.dts > @@ -58,6 +58,24 @@ heartbeat { > }; > }; > > +&gpio0 { > + gpio-line-names = > + /* 0 */ "", "host-reset-control-n", "", "", "", "", "", "", > + /* 8 */ "", "", "", "", "power-chassis-control-n", "", "uid-button", ""; > +}; > + > +&gpio1 { > + gpio-line-names = > + /* 0 */ "", "", "", "", "led-heartbeat", "", "", "led-uid", > + /* 8 */ "", "", "", "", "", "", "", ""; > +}; > + > +&gpio4 { > + gpio-line-names = > + /* 0 */ "", "", "", "", "", "", "", "", > + /* 8 */ "", "", "", "", "", "", "", "power-chassis-good"; > +}; > + > &pinctrl { > key_pins: mux-keys { > groups = "gspi", "sspi"; > -- > 2.35.1 >
diff --git a/arch/arm/boot/dts/nuvoton-wpcm450-supermicro-x9sci-ln4f.dts b/arch/arm/boot/dts/nuvoton-wpcm450-supermicro-x9sci-ln4f.dts index 26fed97f8ff4a..d4472ffdac928 100644 --- a/arch/arm/boot/dts/nuvoton-wpcm450-supermicro-x9sci-ln4f.dts +++ b/arch/arm/boot/dts/nuvoton-wpcm450-supermicro-x9sci-ln4f.dts @@ -58,6 +58,24 @@ heartbeat { }; }; +&gpio0 { + gpio-line-names = + /* 0 */ "", "host-reset-control-n", "", "", "", "", "", "", + /* 8 */ "", "", "", "", "power-chassis-control-n", "", "uid-button", ""; +}; + +&gpio1 { + gpio-line-names = + /* 0 */ "", "", "", "", "led-heartbeat", "", "", "led-uid", + /* 8 */ "", "", "", "", "", "", "", ""; +}; + +&gpio4 { + gpio-line-names = + /* 0 */ "", "", "", "", "", "", "", "", + /* 8 */ "", "", "", "", "", "", "", "power-chassis-good"; +}; + &pinctrl { key_pins: mux-keys { groups = "gspi", "sspi";
To make gpioinfo output more useful and enable gpiofind usage, add line names for GPIOs where the function is known. This patch follows the naming convention defined for OpenBMC, as much as possible: https://github.com/openbmc/docs/blob/master/designs/device-tree-gpio-naming.md Signed-off-by: Jonathan Neuschäfer <j.neuschaefer@gmx.net> --- .../nuvoton-wpcm450-supermicro-x9sci-ln4f.dts | 18 ++++++++++++++++++ 1 file changed, 18 insertions(+) -- 2.35.1