diff mbox series

[next] net: dsa: sja1105: Use struct_size() in kzalloc()

Message ID 20200619181007.GA32353@embeddedor
State Accepted
Delegated to: David Miller
Headers show
Series [next] net: dsa: sja1105: Use struct_size() in kzalloc() | expand

Commit Message

Gustavo A. R. Silva June 19, 2020, 6:10 p.m. UTC
Make use of the struct_size() helper instead of an open-coded version
in order to avoid any potential type mistakes.

This code was detected with the help of Coccinelle and, audited and
fixed manually.

Addresses-KSPP-ID: https://github.com/KSPP/linux/issues/83
Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>
---
 drivers/net/dsa/sja1105/sja1105_tas.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

Comments

Vladimir Oltean June 19, 2020, 7:38 p.m. UTC | #1
Hi Gustavo,

On Fri, 19 Jun 2020 at 21:04, Gustavo A. R. Silva <gustavoars@kernel.org> wrote:
>
> Make use of the struct_size() helper instead of an open-coded version
> in order to avoid any potential type mistakes.
>
> This code was detected with the help of Coccinelle and, audited and
> fixed manually.
>
> Addresses-KSPP-ID: https://github.com/KSPP/linux/issues/83
> Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>
> ---
>  drivers/net/dsa/sja1105/sja1105_tas.c | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/net/dsa/sja1105/sja1105_tas.c b/drivers/net/dsa/sja1105/sja1105_tas.c
> index 3aa1a8b5f766..31d8acff1f01 100644
> --- a/drivers/net/dsa/sja1105/sja1105_tas.c
> +++ b/drivers/net/dsa/sja1105/sja1105_tas.c
> @@ -475,8 +475,7 @@ bool sja1105_gating_check_conflicts(struct sja1105_private *priv, int port,
>         if (list_empty(&gating_cfg->entries))
>                 return false;
>
> -       dummy = kzalloc(sizeof(struct tc_taprio_sched_entry) * num_entries +
> -                       sizeof(struct tc_taprio_qopt_offload), GFP_KERNEL);
> +       dummy = kzalloc(struct_size(dummy, entries, num_entries), GFP_KERNEL);

Before, I could read this line and I knew what it did. Now, I have to
look it up.
But if it's in the interest of kernel coding style, what can I say.

Acked-by: Vladimir Oltean <vladimir.oltean@nxp.com>

>         if (!dummy) {
>                 NL_SET_ERR_MSG_MOD(extack, "Failed to allocate memory");
>                 return true;
> --
> 2.27.0
>
David Miller June 19, 2020, 8:34 p.m. UTC | #2
From: "Gustavo A. R. Silva" <gustavoars@kernel.org>
Date: Fri, 19 Jun 2020 13:10:07 -0500

> Make use of the struct_size() helper instead of an open-coded version
> in order to avoid any potential type mistakes.
> 
> This code was detected with the help of Coccinelle and, audited and
> fixed manually.
> 
> Addresses-KSPP-ID: https://github.com/KSPP/linux/issues/83
> Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>

Applied.
diff mbox series

Patch

diff --git a/drivers/net/dsa/sja1105/sja1105_tas.c b/drivers/net/dsa/sja1105/sja1105_tas.c
index 3aa1a8b5f766..31d8acff1f01 100644
--- a/drivers/net/dsa/sja1105/sja1105_tas.c
+++ b/drivers/net/dsa/sja1105/sja1105_tas.c
@@ -475,8 +475,7 @@  bool sja1105_gating_check_conflicts(struct sja1105_private *priv, int port,
 	if (list_empty(&gating_cfg->entries))
 		return false;
 
-	dummy = kzalloc(sizeof(struct tc_taprio_sched_entry) * num_entries +
-			sizeof(struct tc_taprio_qopt_offload), GFP_KERNEL);
+	dummy = kzalloc(struct_size(dummy, entries, num_entries), GFP_KERNEL);
 	if (!dummy) {
 		NL_SET_ERR_MSG_MOD(extack, "Failed to allocate memory");
 		return true;