Message ID | 20231122060406.14695-2-dlemoal@kernel.org |
---|---|
State | New |
Headers | show |
Series | Cleanup IRQ type definitions | expand |
On Wed, Nov 22, 2023 at 03:03:51PM +0900, Damien Le Moal wrote: > From: Bjorn Helgaas <bhelgaas@google.com> > > Rename PCI_IRQ_LEGACY to PCI_IRQ_INTX to be more explicit about the type > of IRQ being referenced as well as to match the PCI specifications > terms. Redefine PCI_IRQ_LEGACY as an alias to PCI_IRQ_INTX to avoid the > need for doing the renaming tree-wide. New drivers and new code should > now prefer using PCI_IRQ_INTX instead of PCI_IRQ_LEGACY. Sorry for picking this horrible name back in the day. Reviewed-by: Christoph Hellwig <hch@lst.de> (and please run a script to fix this up after the next -rc1)
diff --git a/include/linux/pci.h b/include/linux/pci.h index 60ca768bc867..9ab4b46c0d19 100644 --- a/include/linux/pci.h +++ b/include/linux/pci.h @@ -1073,11 +1073,13 @@ enum { PCI_SCAN_ALL_PCIE_DEVS = 0x00000040, /* Scan all, not just dev 0 */ }; -#define PCI_IRQ_LEGACY (1 << 0) /* Allow legacy interrupts */ +#define PCI_IRQ_INTX (1 << 0) /* Allow INTx interrupts */ #define PCI_IRQ_MSI (1 << 1) /* Allow MSI interrupts */ #define PCI_IRQ_MSIX (1 << 2) /* Allow MSI-X interrupts */ #define PCI_IRQ_AFFINITY (1 << 3) /* Auto-assign affinity */ +#define PCI_IRQ_LEGACY PCI_IRQ_INTX /* Deprecated! Use PCI_IRQ_INTX */ + /* These external functions are only available when PCI support is enabled */ #ifdef CONFIG_PCI