Message ID | 1459222998-2855-1-git-send-email-horms+renesas@verge.net.au |
---|---|
State | Superseded |
Headers | show |
On Tue, Mar 29, 2016 at 5:43 AM, Simon Horman <horms+renesas@verge.net.au> wrote: > It appears that Gen2 is a misnomer for the R-Car PCIE driver > which also supports Gen 1 and Gen 3 SoCs. Accordingly, drop Gen 2 > from the help text and Kconfig symbol. > > Reported-by: Geert Uytterhoeven <geert+renesas@glider.be> > Signed-off-by: Simon Horman <horms+renesas@verge.net.au> > --- > Bjorn, if this patch is acceptable I would like to request that we > co-ordinate things so that I can queue-up corresponding updates for > arm and arm64 defconfigs in the same release. From my point of view > v4.7 would make sense. > --- > drivers/pci/host/Kconfig | 4 ++-- > drivers/pci/host/Makefile | 2 +- > 2 files changed, 3 insertions(+), 3 deletions(-) > > diff --git a/drivers/pci/host/Kconfig b/drivers/pci/host/Kconfig > index 7a0780d56d2d..9109c6c5298c 100644 > --- a/drivers/pci/host/Kconfig > +++ b/drivers/pci/host/Kconfig > @@ -69,11 +69,11 @@ config PCI_RCAR_GEN2 > There are 3 internal PCI controllers available with a single > built-in EHCI/OHCI host controller present on each one. > > -config PCI_RCAR_GEN2_PCIE > +config PCI_RCAR_PCIE Following the pattern in drivers/pci/host/Kconfig, I think this symbol should be called PCIE_RCAR. Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds -- To unsubscribe from this list: send the line "unsubscribe linux-pci" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On Tue, Mar 29, 2016 at 08:50:55AM +0200, Geert Uytterhoeven wrote: > On Tue, Mar 29, 2016 at 5:43 AM, Simon Horman > <horms+renesas@verge.net.au> wrote: > > It appears that Gen2 is a misnomer for the R-Car PCIE driver > > which also supports Gen 1 and Gen 3 SoCs. Accordingly, drop Gen 2 > > from the help text and Kconfig symbol. > > > > Reported-by: Geert Uytterhoeven <geert+renesas@glider.be> > > Signed-off-by: Simon Horman <horms+renesas@verge.net.au> > > --- > > Bjorn, if this patch is acceptable I would like to request that we > > co-ordinate things so that I can queue-up corresponding updates for > > arm and arm64 defconfigs in the same release. From my point of view > > v4.7 would make sense. > > --- > > drivers/pci/host/Kconfig | 4 ++-- > > drivers/pci/host/Makefile | 2 +- > > 2 files changed, 3 insertions(+), 3 deletions(-) > > > > diff --git a/drivers/pci/host/Kconfig b/drivers/pci/host/Kconfig > > index 7a0780d56d2d..9109c6c5298c 100644 > > --- a/drivers/pci/host/Kconfig > > +++ b/drivers/pci/host/Kconfig > > @@ -69,11 +69,11 @@ config PCI_RCAR_GEN2 > > There are 3 internal PCI controllers available with a single > > built-in EHCI/OHCI host controller present on each one. > > > > -config PCI_RCAR_GEN2_PCIE > > +config PCI_RCAR_PCIE > > Following the pattern in drivers/pci/host/Kconfig, I think this symbol should > be called PCIE_RCAR. Short is nice :) I will send v2. -- To unsubscribe from this list: send the line "unsubscribe linux-pci" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
diff --git a/drivers/pci/host/Kconfig b/drivers/pci/host/Kconfig index 7a0780d56d2d..9109c6c5298c 100644 --- a/drivers/pci/host/Kconfig +++ b/drivers/pci/host/Kconfig @@ -69,11 +69,11 @@ config PCI_RCAR_GEN2 There are 3 internal PCI controllers available with a single built-in EHCI/OHCI host controller present on each one. -config PCI_RCAR_GEN2_PCIE +config PCI_RCAR_PCIE bool "Renesas R-Car PCIe controller" depends on ARCH_RENESAS || (ARM && COMPILE_TEST) help - Say Y here if you want PCIe controller support on R-Car Gen2 SoCs. + Say Y here if you want PCIe controller support on R-Car SoCs. config PCI_HOST_COMMON bool diff --git a/drivers/pci/host/Makefile b/drivers/pci/host/Makefile index d85b5faf9bbc..042cf32c14ca 100644 --- a/drivers/pci/host/Makefile +++ b/drivers/pci/host/Makefile @@ -7,7 +7,7 @@ obj-$(CONFIG_PCI_HYPERV) += pci-hyperv.o obj-$(CONFIG_PCI_MVEBU) += pci-mvebu.o obj-$(CONFIG_PCI_TEGRA) += pci-tegra.o obj-$(CONFIG_PCI_RCAR_GEN2) += pci-rcar-gen2.o -obj-$(CONFIG_PCI_RCAR_GEN2_PCIE) += pcie-rcar.o +obj-$(CONFIG_PCI_RCAR_PCIE) += pcie-rcar.o obj-$(CONFIG_PCI_HOST_COMMON) += pci-host-common.o obj-$(CONFIG_PCI_HOST_GENERIC) += pci-host-generic.o obj-$(CONFIG_PCIE_SPEAR13XX) += pcie-spear13xx.o
It appears that Gen2 is a misnomer for the R-Car PCIE driver which also supports Gen 1 and Gen 3 SoCs. Accordingly, drop Gen 2 from the help text and Kconfig symbol. Reported-by: Geert Uytterhoeven <geert+renesas@glider.be> Signed-off-by: Simon Horman <horms+renesas@verge.net.au> --- Bjorn, if this patch is acceptable I would like to request that we co-ordinate things so that I can queue-up corresponding updates for arm and arm64 defconfigs in the same release. From my point of view v4.7 would make sense. --- drivers/pci/host/Kconfig | 4 ++-- drivers/pci/host/Makefile | 2 +- 2 files changed, 3 insertions(+), 3 deletions(-)