mbox series

[v3,0/2] PCI/pwrctl: fixes for v6.11

Message ID 20240823093323.33450-1-brgl@bgdev.pl
Headers show
Series PCI/pwrctl: fixes for v6.11 | expand

Message

Bartosz Golaszewski Aug. 23, 2024, 9:33 a.m. UTC
From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

Bjorn,

Here's a respin of the PCI/pwrctl fixes that should go into v6.11. I
eventually found a solution that doesn't require Krishna's topology
change but Krishna: please make sure to update the code in
drivers/pci/remove.c as well when rebasing your work once this gets
upstream.

v2 -> v3:
- use the correct device for unregistering the platform pwrctl device in
  patch 1/2
- make patch 1/2 easier to read by using device_for_each_child()

v1 -> v2:
- use the scoped variant of for_each_child_of_node() to fix a memory
  leak in patch 1/2

Bartosz Golaszewski (2):
  PCI: don't rely on of_platform_depopulate() for reused OF-nodes
  PCI/pwrctl: put the bus rescan on a different thread

 drivers/pci/pwrctl/core.c              | 26 +++++++++++++++++++++++---
 drivers/pci/pwrctl/pci-pwrctl-pwrseq.c |  2 +-
 drivers/pci/remove.c                   | 18 +++++++++++++++++-
 include/linux/pci-pwrctl.h             |  3 +++
 4 files changed, 44 insertions(+), 5 deletions(-)

Comments

Bartosz Golaszewski Sept. 2, 2024, 7:42 a.m. UTC | #1
On Fri, Aug 23, 2024 at 11:33 AM Bartosz Golaszewski <brgl@bgdev.pl> wrote:
>
> From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
>
> Bjorn,
>
> Here's a respin of the PCI/pwrctl fixes that should go into v6.11. I
> eventually found a solution that doesn't require Krishna's topology
> change but Krishna: please make sure to update the code in
> drivers/pci/remove.c as well when rebasing your work once this gets
> upstream.
>
> v2 -> v3:
> - use the correct device for unregistering the platform pwrctl device in
>   patch 1/2
> - make patch 1/2 easier to read by using device_for_each_child()
>
> v1 -> v2:
> - use the scoped variant of for_each_child_of_node() to fix a memory
>   leak in patch 1/2
>
> Bartosz Golaszewski (2):
>   PCI: don't rely on of_platform_depopulate() for reused OF-nodes
>   PCI/pwrctl: put the bus rescan on a different thread
>
>  drivers/pci/pwrctl/core.c              | 26 +++++++++++++++++++++++---
>  drivers/pci/pwrctl/pci-pwrctl-pwrseq.c |  2 +-
>  drivers/pci/remove.c                   | 18 +++++++++++++++++-
>  include/linux/pci-pwrctl.h             |  3 +++
>  4 files changed, 44 insertions(+), 5 deletions(-)
>
> --
> 2.43.0
>

Bjorn: gentle ping. Neither Rob nor Mani are opposed to these and it's
getting close to release. Could you please pick them up?

Bart
Bjorn Helgaas Sept. 3, 2024, 10:13 p.m. UTC | #2
On Fri, Aug 23, 2024 at 11:33:21AM +0200, Bartosz Golaszewski wrote:
> From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> 
> Bjorn,
> 
> Here's a respin of the PCI/pwrctl fixes that should go into v6.11. I
> eventually found a solution that doesn't require Krishna's topology
> change but Krishna: please make sure to update the code in
> drivers/pci/remove.c as well when rebasing your work once this gets
> upstream.
> 
> v2 -> v3:
> - use the correct device for unregistering the platform pwrctl device in
>   patch 1/2
> - make patch 1/2 easier to read by using device_for_each_child()
> 
> v1 -> v2:
> - use the scoped variant of for_each_child_of_node() to fix a memory
>   leak in patch 1/2
> 
> Bartosz Golaszewski (2):
>   PCI: don't rely on of_platform_depopulate() for reused OF-nodes
>   PCI/pwrctl: put the bus rescan on a different thread
> 
>  drivers/pci/pwrctl/core.c              | 26 +++++++++++++++++++++++---
>  drivers/pci/pwrctl/pci-pwrctl-pwrseq.c |  2 +-
>  drivers/pci/remove.c                   | 18 +++++++++++++++++-
>  include/linux/pci-pwrctl.h             |  3 +++
>  4 files changed, 44 insertions(+), 5 deletions(-)

Applied to pci/for-linus for v6.11, thanks.