Message ID | 20210603123041.12036-1-thunder.leizhen@huawei.com |
---|---|
State | Accepted |
Headers | show |
Series | [1/1] mtd: mtdpart: use DEVICE_ATTR_RO() helper macro | expand |
On Thu, 2021-06-03 at 12:30:41 UTC, Zhen Lei wrote: > Use DEVICE_ATTR_RO() helper macro instead of plain DEVICE_ATTR(), which > makes the code a bit shorter and easier to read. > > Signed-off-by: Zhen Lei <thunder.leizhen@huawei.com> Applied to https://git.kernel.org/pub/scm/linux/kernel/git/mtd/linux.git mtd/next, thanks. Miquel
diff --git a/drivers/mtd/mtdpart.c b/drivers/mtd/mtdpart.c index 66a67c6e3cbc049..04af12b66110c60 100644 --- a/drivers/mtd/mtdpart.c +++ b/drivers/mtd/mtdpart.c @@ -212,15 +212,14 @@ static struct mtd_info *allocate_partition(struct mtd_info *parent, return child; } -static ssize_t mtd_partition_offset_show(struct device *dev, - struct device_attribute *attr, char *buf) +static ssize_t offset_show(struct device *dev, + struct device_attribute *attr, char *buf) { struct mtd_info *mtd = dev_get_drvdata(dev); return sysfs_emit(buf, "%lld\n", mtd->part.offset); } - -static DEVICE_ATTR(offset, S_IRUGO, mtd_partition_offset_show, NULL); +static DEVICE_ATTR_RO(offset); /* mtd partition offset */ static const struct attribute *mtd_partition_attrs[] = { &dev_attr_offset.attr,
Use DEVICE_ATTR_RO() helper macro instead of plain DEVICE_ATTR(), which makes the code a bit shorter and easier to read. Signed-off-by: Zhen Lei <thunder.leizhen@huawei.com> --- drivers/mtd/mtdpart.c | 7 +++---- 1 file changed, 3 insertions(+), 4 deletions(-)