Message ID | 20230309154949.658380-2-krzysztof.kozlowski@linaro.org |
---|---|
State | New |
Headers | show |
Series | [1/4] pinctrl: qcom: lpass-lpi: set output value before enabling output | expand |
On 9.03.2023 16:49, Krzysztof Kozlowski wrote: > The set_mux callback in SoC TLMM driver (pinctrl-msm.c) uses "group", > not "group_num" for the number of the pin group. Other places of > lpass-lpi also use "group", so let's be consistent for code readability. > > Signed-off-by: Krzysztof Kozlowski <krzysztof.kozlowski@linaro.org> > --- Reviewed-by: Konrad Dybcio <konrad.dybcio@linaro.org> Konrad > drivers/pinctrl/qcom/pinctrl-lpass-lpi.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/pinctrl/qcom/pinctrl-lpass-lpi.c b/drivers/pinctrl/qcom/pinctrl-lpass-lpi.c > index 27fc8b671954..bd32556d75a5 100644 > --- a/drivers/pinctrl/qcom/pinctrl-lpass-lpi.c > +++ b/drivers/pinctrl/qcom/pinctrl-lpass-lpi.c > @@ -84,10 +84,10 @@ static int lpi_gpio_get_function_groups(struct pinctrl_dev *pctldev, > } > > static int lpi_gpio_set_mux(struct pinctrl_dev *pctldev, unsigned int function, > - unsigned int group_num) > + unsigned int group) > { > struct lpi_pinctrl *pctrl = pinctrl_dev_get_drvdata(pctldev); > - const struct lpi_pingroup *g = &pctrl->data->groups[group_num]; > + const struct lpi_pingroup *g = &pctrl->data->groups[group]; > u32 val; > int i, pin = g->pin; >
diff --git a/drivers/pinctrl/qcom/pinctrl-lpass-lpi.c b/drivers/pinctrl/qcom/pinctrl-lpass-lpi.c index 27fc8b671954..bd32556d75a5 100644 --- a/drivers/pinctrl/qcom/pinctrl-lpass-lpi.c +++ b/drivers/pinctrl/qcom/pinctrl-lpass-lpi.c @@ -84,10 +84,10 @@ static int lpi_gpio_get_function_groups(struct pinctrl_dev *pctldev, } static int lpi_gpio_set_mux(struct pinctrl_dev *pctldev, unsigned int function, - unsigned int group_num) + unsigned int group) { struct lpi_pinctrl *pctrl = pinctrl_dev_get_drvdata(pctldev); - const struct lpi_pingroup *g = &pctrl->data->groups[group_num]; + const struct lpi_pingroup *g = &pctrl->data->groups[group]; u32 val; int i, pin = g->pin;
The set_mux callback in SoC TLMM driver (pinctrl-msm.c) uses "group", not "group_num" for the number of the pin group. Other places of lpass-lpi also use "group", so let's be consistent for code readability. Signed-off-by: Krzysztof Kozlowski <krzysztof.kozlowski@linaro.org> --- drivers/pinctrl/qcom/pinctrl-lpass-lpi.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)