Message ID | 1473085895-31711-2-git-send-email-bgolaszewski@baylibre.com |
---|---|
State | New |
Headers | show |
On Mon, Sep 5, 2016 at 4:31 PM, Bartosz Golaszewski <bgolaszewski@baylibre.com> wrote: > pca953x_gpio_set_multiple() has some coding style issues that make it > harder to read. Tweak the code a bit. > > Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Much better like this. Patch applied. Yours, Linus Walleij -- To unsubscribe from this list: send the line "unsubscribe linux-gpio" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On Wed, Sep 7, 2016 at 11:55 PM, Linus Walleij <linus.walleij@linaro.org> wrote: > On Mon, Sep 5, 2016 at 4:31 PM, Bartosz Golaszewski > <bgolaszewski@baylibre.com> wrote: > >> pca953x_gpio_set_multiple() has some coding style issues that make it >> harder to read. Tweak the code a bit. >> >> Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> > > Much better like this. > > Patch applied. Ah I see there was a later version and it was moved around. OK backing this out. Let's go for latest version and also please rebase it onto my devel branch. Yours, Linus Walleij -- To unsubscribe from this list: send the line "unsubscribe linux-gpio" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
2016-09-08 1:15 GMT+02:00 Linus Walleij <linus.walleij@linaro.org>: > On Wed, Sep 7, 2016 at 11:55 PM, Linus Walleij <linus.walleij@linaro.org> wrote: >> On Mon, Sep 5, 2016 at 4:31 PM, Bartosz Golaszewski >> <bgolaszewski@baylibre.com> wrote: >> >>> pca953x_gpio_set_multiple() has some coding style issues that make it >>> harder to read. Tweak the code a bit. >>> >>> Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> >> >> Much better like this. >> >> Patch applied. > > Ah I see there was a later version and it was moved around. > > OK backing this out. Let's go for latest version and also please > rebase it onto my devel branch. > > Yours, > Linus Walleij Done. The current, rebased version is v6. Thanks, Bartosz -- To unsubscribe from this list: send the line "unsubscribe linux-gpio" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
diff --git a/drivers/gpio/gpio-pca953x.c b/drivers/gpio/gpio-pca953x.c index 02f2a56..2312f8d 100644 --- a/drivers/gpio/gpio-pca953x.c +++ b/drivers/gpio/gpio-pca953x.c @@ -355,13 +355,13 @@ exit: } static void pca953x_gpio_set_multiple(struct gpio_chip *gc, - unsigned long *mask, unsigned long *bits) + unsigned long *mask, unsigned long *bits) { struct pca953x_chip *chip = gpiochip_get_data(gc); u8 reg_val[MAX_BANK]; - int ret, offset = 0; + int ret, bank, offset = 0; int bank_shift = fls((chip->gpio_chip.ngpio - 1) / BANK_SZ); - int bank; + unsigned int bankmask, bankval; switch (chip->chip_type) { case PCA953X_TYPE: @@ -374,15 +374,16 @@ static void pca953x_gpio_set_multiple(struct gpio_chip *gc, memcpy(reg_val, chip->reg_output, NBANK(chip)); mutex_lock(&chip->i2c_lock); - for(bank=0; bank<NBANK(chip); bank++) { - unsigned bankmask = mask[bank / sizeof(*mask)] >> - ((bank % sizeof(*mask)) * 8); - if(bankmask) { - unsigned bankval = bits[bank / sizeof(*bits)] >> - ((bank % sizeof(*bits)) * 8); + for (bank = 0; bank < NBANK(chip); bank++) { + bankmask = mask[bank / sizeof(*mask)] >> + ((bank % sizeof(*mask)) * 8); + if (bankmask) { + bankval = bits[bank / sizeof(*bits)] >> + ((bank % sizeof(*bits)) * 8); reg_val[bank] = (reg_val[bank] & ~bankmask) | bankval; } } + ret = i2c_smbus_write_i2c_block_data(chip->client, offset << bank_shift, NBANK(chip), reg_val); if (ret) goto exit;
pca953x_gpio_set_multiple() has some coding style issues that make it harder to read. Tweak the code a bit. Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> --- drivers/gpio/gpio-pca953x.c | 19 ++++++++++--------- 1 file changed, 10 insertions(+), 9 deletions(-)