diff mbox series

tests: XFAIL audit tests failing on mips due to bug 29404

Message ID 20240712081818.46610-1-dilfridge@gentoo.org
State New
Headers show
Series tests: XFAIL audit tests failing on mips due to bug 29404 | expand

Commit Message

Andreas K. Huettel July 12, 2024, 8:15 a.m. UTC
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
---
I understand Adhemerval's comment on bug 29404 such that these 6 tests always
fail on mips at the moment, due to limitations in the audit code(?).
It makes no sense to limit the testsuite passing on them in that case
(but the bug should stay open)...
The whitespace error is added by autoconf.
---
 sysdeps/mips/configure    | 14 ++++++++++++++
 sysdeps/mips/configure.ac |  8 ++++++++
 2 files changed, 22 insertions(+)

Comments

Adhemerval Zanella Netto July 12, 2024, 1:56 p.m. UTC | #1
On 12/07/24 05:15, Andreas K. Hüttel wrote:
> Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
> ---
> I understand Adhemerval's comment on bug 29404 such that these 6 tests always
> fail on mips at the moment, due to limitations in the audit code(?).
> It makes no sense to limit the testsuite passing on them in that case
> (but the bug should stay open)...
> The whitespace error is added by autoconf.

Sometime ago I tried briefly to make it work on MIPS, but it seems that its
ABI tends to generated code similar to -fno-plt and I could not find a way
to make the PLT hooks to work correctly.

And I don't think you need to mess with configure, just add it on the
Makefile:

diff --git a/sysdeps/mips/Makefile b/sysdeps/mips/Makefile
index d770e59fc9..d189973aa0 100644
--- a/sysdeps/mips/Makefile
+++ b/sysdeps/mips/Makefile
@@ -23,6 +23,15 @@ ASFLAGS-.o += $(pie-default)
 ASFLAGS-.op += $(pie-default)

 ifeq ($(subdir),elf)
+
+# These tests fail on all mips configurations (BZ 29404)
+test-xfail-tst-audit24a = yes
+test-xfail-tst-audit24b = yes
+test-xfail-tst-audit24c = yes
+test-xfail-tst-audit24d = yes
+test-xfail-tst-audit25a = yes
+test-xfail-tst-audit25b = yes
+
 ifneq ($(o32-fpabi),)
 tests += tst-abi-interlink


> ---
>  sysdeps/mips/configure    | 14 ++++++++++++++
>  sysdeps/mips/configure.ac |  8 ++++++++
>  2 files changed, 22 insertions(+)
> 
> diff --git a/sysdeps/mips/configure b/sysdeps/mips/configure
> index 60dbd947e2..7c8eec8f06 100644
> --- a/sysdeps/mips/configure
> +++ b/sysdeps/mips/configure
> @@ -172,3 +172,17 @@ if test x$libc_cv_mips_nan2008 = xyes; then
>  
>  fi
>  
> +# bug 29404 - these tests right now fail for any mips build
> +config_vars="$config_vars
> +test-xfail-tst-audit24a = yes"
> +config_vars="$config_vars
> +test-xfail-tst-audit24b = yes"
> +config_vars="$config_vars
> +test-xfail-tst-audit24c = yes"
> +config_vars="$config_vars
> +test-xfail-tst-audit24d = yes"
> +config_vars="$config_vars
> +test-xfail-tst-audit25a = yes"
> +config_vars="$config_vars
> +test-xfail-tst-audit25b = yes"
> +
> diff --git a/sysdeps/mips/configure.ac b/sysdeps/mips/configure.ac
> index d3cd780d78..facc68e5c0 100644
> --- a/sysdeps/mips/configure.ac
> +++ b/sysdeps/mips/configure.ac
> @@ -13,3 +13,11 @@ yes
>  if test x$libc_cv_mips_nan2008 = xyes; then
>    AC_DEFINE(HAVE_MIPS_NAN2008)
>  fi
> +
> +# bug 29404 - these tests right now fail for any mips build
> +LIBC_CONFIG_VAR([test-xfail-tst-audit24a], [yes])
> +LIBC_CONFIG_VAR([test-xfail-tst-audit24b], [yes])
> +LIBC_CONFIG_VAR([test-xfail-tst-audit24c], [yes])
> +LIBC_CONFIG_VAR([test-xfail-tst-audit24d], [yes])
> +LIBC_CONFIG_VAR([test-xfail-tst-audit25a], [yes])
> +LIBC_CONFIG_VAR([test-xfail-tst-audit25b], [yes])
diff mbox series

Patch

diff --git a/sysdeps/mips/configure b/sysdeps/mips/configure
index 60dbd947e2..7c8eec8f06 100644
--- a/sysdeps/mips/configure
+++ b/sysdeps/mips/configure
@@ -172,3 +172,17 @@  if test x$libc_cv_mips_nan2008 = xyes; then
 
 fi
 
+# bug 29404 - these tests right now fail for any mips build
+config_vars="$config_vars
+test-xfail-tst-audit24a = yes"
+config_vars="$config_vars
+test-xfail-tst-audit24b = yes"
+config_vars="$config_vars
+test-xfail-tst-audit24c = yes"
+config_vars="$config_vars
+test-xfail-tst-audit24d = yes"
+config_vars="$config_vars
+test-xfail-tst-audit25a = yes"
+config_vars="$config_vars
+test-xfail-tst-audit25b = yes"
+
diff --git a/sysdeps/mips/configure.ac b/sysdeps/mips/configure.ac
index d3cd780d78..facc68e5c0 100644
--- a/sysdeps/mips/configure.ac
+++ b/sysdeps/mips/configure.ac
@@ -13,3 +13,11 @@  yes
 if test x$libc_cv_mips_nan2008 = xyes; then
   AC_DEFINE(HAVE_MIPS_NAN2008)
 fi
+
+# bug 29404 - these tests right now fail for any mips build
+LIBC_CONFIG_VAR([test-xfail-tst-audit24a], [yes])
+LIBC_CONFIG_VAR([test-xfail-tst-audit24b], [yes])
+LIBC_CONFIG_VAR([test-xfail-tst-audit24c], [yes])
+LIBC_CONFIG_VAR([test-xfail-tst-audit24d], [yes])
+LIBC_CONFIG_VAR([test-xfail-tst-audit25a], [yes])
+LIBC_CONFIG_VAR([test-xfail-tst-audit25b], [yes])