diff mbox series

[2/2] ipa-cp: One more use of ipa_vr_supported_type_p

Message ID ri6r09qe7ol.fsf@virgil.suse.cz
State New
Headers show
Series [1/2] ipa: Rename ipa_supports_p to ipa_vr_supported_type_p | expand

Commit Message

Martin Jambor Sept. 11, 2024, 11:44 a.m. UTC
Hi,

Since we have the predicate, this patch converts one more check for
essentially the same thing into its use.

It has passed a bootstrap and testsuite on x86_64.  I believe it is
obvious enough that I can commit it myself and so will do so later
today.

Thanks,

Martin


2024-09-11  Martin Jambor  <mjambor@suse.cz>

	* gcc/ipa-cp.cc (propagate_vr_across_jump_function): Use
	ipa_vr_supported_type_p instead of explicit check for integral and
	pointer types.
---
 gcc/ipa-cp.cc | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gcc/ipa-cp.cc b/gcc/ipa-cp.cc
index a1033b81aef..fa7bd6a15da 100644
--- a/gcc/ipa-cp.cc
+++ b/gcc/ipa-cp.cc
@@ -2519,8 +2519,7 @@  propagate_vr_across_jump_function (cgraph_edge *cs, ipa_jump_func *jfunc,
     return false;
 
   if (!param_type
-      || (!INTEGRAL_TYPE_P (param_type)
-	  && !POINTER_TYPE_P (param_type)))
+      || !ipa_vr_supported_type_p (param_type))
     return dest_lat->set_to_bottom ();
 
   if (jfunc->type == IPA_JF_PASS_THROUGH)