mbox series

[0/4] vect: Rename/refactor some codes related to fully masking

Message ID 8107a42b-92e8-56f1-0721-8e594c18b8ed@linux.ibm.com
Headers show
Series vect: Rename/refactor some codes related to fully masking | expand

Message

Kewen.Lin June 10, 2020, 6:31 a.m. UTC
Hi all,

As Richard suggested in vector with length reviews here
https://gcc.gnu.org/pipermail/gcc-patches/2020-June/547077.html,
this series is responsible for some renaming and refactoring
related to existing fully masking supports.  Since we are going
to introduce length-based partial vectorization, some data
structures, flags, functions can be renamed/factored to be used
for partial vectorization (mask-based or length-based).

All four patches have been bootstrapped and passed regress testing
on aarch64-linux-gnu (incrementally, not all in one).

Is it OK for trunk?

BR,
Kewen
-----

outline:
 - [PATCH 1/4] vect: Rename can_fully_mask_p to can_use_partial_vectors_p
 - [PATCH 2/4] vect: Rename fully_masked_p to using_partial_vectors_p
 - [PATCH 3/4] vect: Rename things related to rgroup_masks
 - [PATCH 4/4] vect: Factor out and rename some functions/macros

---
 gcc/tree-vect-loop-manip.c | 218 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++-------------------------------------------------------------
 gcc/tree-vect-loop.c       | 214 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++---------------------------------------------------
 gcc/tree-vect-stmts.c      |  59 +++++++++++++++++----------------
 gcc/tree-vectorizer.h      |  78 ++++++++++++++++++++++++--------------------
 4 files changed, 306 insertions(+), 263 deletions(-)