diff mbox series

[1/5] package/gpsd: condition python stuff to the proper kconfig option

Message ID f068a1d175dd8472c8ff10ffb5607d96d760e1a0.1720535037.git.yann.morin@orange.com
State Accepted
Headers show
Series [1/5] package/gpsd: condition python stuff to the proper kconfig option | expand

Commit Message

Yann E. MORIN July 9, 2024, 2:23 p.m. UTC
From: "Yann E. MORIN" <yann.morin@orange.com>

Currently, we have a Kconfig symbol to enable the python support in
gpsd, but the condition at configure time is based on whether the python
package is enabled. So, if a user does not enable python support in
gpsd, they still get it.

Switch to using the proper symbol.

Signed-off-by: Yann E. MORIN <yann.morin@orange.com>
Cc: Bernd Kuhls <bernd@kuhls.net>
---
 package/gpsd/gpsd.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Jan Havran July 14, 2024, 9:52 p.m. UTC | #1
Hi,

V Tue, Jul 09, 2024 at 04:23:57PM +0200, yann.morin@orange.com napsal(a):
> From: "Yann E. MORIN" <yann.morin@orange.com>
> 
> Currently, we have a Kconfig symbol to enable the python support in
> gpsd, but the condition at configure time is based on whether the python
> package is enabled. So, if a user does not enable python support in
> gpsd, they still get it.
> 
> Switch to using the proper symbol.
> 
> Signed-off-by: Yann E. MORIN <yann.morin@orange.com>
> Cc: Bernd Kuhls <bernd@kuhls.net>

Reviewed-by: Jan Havran <havran.jan@email.cz>

> ---
>  package/gpsd/gpsd.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/gpsd/gpsd.mk b/package/gpsd/gpsd.mk
> index 1d4013d122..c57fad83c3 100644
> --- a/package/gpsd/gpsd.mk
> +++ b/package/gpsd/gpsd.mk
> @@ -178,7 +178,7 @@ ifeq ($(BR2_PACKAGE_GPSD_MAX_DEV),y)
>  GPSD_SCONS_OPTS += max_devices=$(BR2_PACKAGE_GPSD_MAX_DEV_VALUE)
>  endif
>  
> -ifeq ($(BR2_PACKAGE_PYTHON3),y)
> +ifeq ($(BR2_PACKAGE_GPSD_PYTHON),y)
>  GPSD_SCONS_OPTS += \
>  	python=yes \
>  	python_libdir="/usr/lib/python$(PYTHON3_VERSION_MAJOR)/site-packages"
Peter Korsgaard Sept. 3, 2024, 6:02 p.m. UTC | #2
>>>>>   <yann.morin@orange.com> writes:

 > From: "Yann E. MORIN" <yann.morin@orange.com>
 > Currently, we have a Kconfig symbol to enable the python support in
 > gpsd, but the condition at configure time is based on whether the python
 > package is enabled. So, if a user does not enable python support in
 > gpsd, they still get it.

 > Switch to using the proper symbol.

 > Signed-off-by: Yann E. MORIN <yann.morin@orange.com>
 > Cc: Bernd Kuhls <bernd@kuhls.net>

Committed to 2024.02.x and 2024.05.x, thanks.
diff mbox series

Patch

diff --git a/package/gpsd/gpsd.mk b/package/gpsd/gpsd.mk
index 1d4013d122..c57fad83c3 100644
--- a/package/gpsd/gpsd.mk
+++ b/package/gpsd/gpsd.mk
@@ -178,7 +178,7 @@  ifeq ($(BR2_PACKAGE_GPSD_MAX_DEV),y)
 GPSD_SCONS_OPTS += max_devices=$(BR2_PACKAGE_GPSD_MAX_DEV_VALUE)
 endif
 
-ifeq ($(BR2_PACKAGE_PYTHON3),y)
+ifeq ($(BR2_PACKAGE_GPSD_PYTHON),y)
 GPSD_SCONS_OPTS += \
 	python=yes \
 	python_libdir="/usr/lib/python$(PYTHON3_VERSION_MAJOR)/site-packages"