diff mbox series

[2/2] package/qemu: update to 9.1.0

Message ID ZubuMtvyrh/8Nj/W@waldemar-brodkorb.de
State Superseded
Headers show
Series [1/2] configs/qemu_nios2_10m50: delete config | expand

Commit Message

Waldemar Brodkorb Sept. 15, 2024, 2:24 p.m. UTC
See here for changes:
https://wiki.qemu.org/ChangeLog/9.1

The support for the nios2 architecture got removed.

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
---
 package/qemu/Config.in      | 5 -----
 package/qemu/Config.in.host | 1 -
 package/qemu/qemu.hash      | 2 +-
 package/qemu/qemu.mk        | 2 +-
 4 files changed, 2 insertions(+), 8 deletions(-)

Comments

Romain Naour Sept. 15, 2024, 4:01 p.m. UTC | #1
Hello Waldemar,

Le 15/09/2024 à 16:24, Waldemar Brodkorb a écrit :
> See here for changes:
> https://wiki.qemu.org/ChangeLog/9.1
> 
> The support for the nios2 architecture got removed.

How did you test this version bump?

I would recommend to use gitlab-ci and push a branch with a specific name: <qemu
version>-defconfigs-qemu (see [1][2][3]).

Note: With the gitlab-ci free tier (using shared gitlab-ci runners), defconfigs
like the qemu_aarch64_sbsa_defconfig takes too long to build and reach the 6h
job timeout or filesystem size limit.

[1] https://gitlab.com/kubu93/buildroot/-/commits/qemu-8.2.1-defconfigs-qemu
[2] https://gitlab.com/kubu93/buildroot/-/pipelines/1167866790
[3] https://www.linuxembedded.fr/2022/01/buildroot-gitlab-ci-testing

> 
> Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
> ---
>  package/qemu/Config.in      | 5 -----
>  package/qemu/Config.in.host | 1 -
>  package/qemu/qemu.hash      | 2 +-
>  package/qemu/qemu.mk        | 2 +-
>  4 files changed, 2 insertions(+), 8 deletions(-)
> 
> diff --git a/package/qemu/Config.in b/package/qemu/Config.in
> index 608e4d429d..2d15ab1ea9 100644
> --- a/package/qemu/Config.in
> +++ b/package/qemu/Config.in
> @@ -252,11 +252,6 @@ config BR2_PACKAGE_QEMU_TARGET_MIPSN32EL
>  	help
>  	  MIPS N32 architecture, little-endian.
>  
> -config BR2_PACKAGE_QEMU_TARGET_NIOS2
> -	bool "nios2"
> -	help
> -	  Nios II architecture.

Removing this option needs legacy handling in Config.in.legacy.

Best regards,
Romain


> -
>  config BR2_PACKAGE_QEMU_TARGET_OR1K
>  	bool "or1k"
>  	select BR2_PACKAGE_QEMU_FDT if BR2_PACKAGE_QEMU_SYSTEM
> diff --git a/package/qemu/Config.in.host b/package/qemu/Config.in.host
> index 8dd0c7d11b..4db114490a 100644
> --- a/package/qemu/Config.in.host
> +++ b/package/qemu/Config.in.host
> @@ -9,7 +9,6 @@ config BR2_PACKAGE_HOST_QEMU_ARCH_SUPPORTS
>  	default y if BR2_microblazebe
>  	default y if BR2_mips
>  	default y if BR2_mipsel
> -	default y if BR2_nios2
>  	default y if BR2_or1k
>  	default y if BR2_powerpc
>  	default y if BR2_powerpc64
> diff --git a/package/qemu/qemu.hash b/package/qemu/qemu.hash
> index 419dd0d1b3..169fe05068 100644
> --- a/package/qemu/qemu.hash
> +++ b/package/qemu/qemu.hash
> @@ -1,4 +1,4 @@
>  # Locally computed, tarball verified with GPG signature
> -sha256  a8c3f596aece96da3b00cafb74baafa0d14515eafb8ed1ee3f7f5c2d0ebf02b6  qemu-9.0.2.tar.xz
> +sha256  816b7022a8ba7c2ac30e2e0cf973e826f6bcc8505339603212c5ede8e94d7834  qemu-9.1.0.tar.xz
>  sha256  6f04ae8364d0079a192b14635f4b1da294ce18724c034c39a6a41d1b09df6100  COPYING
>  sha256  dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  COPYING.LIB
> diff --git a/package/qemu/qemu.mk b/package/qemu/qemu.mk
> index 16cff13d18..e9f6520d89 100644
> --- a/package/qemu/qemu.mk
> +++ b/package/qemu/qemu.mk
> @@ -6,7 +6,7 @@
>  
>  # When updating the version, check whether the list of supported targets
>  # needs to be updated.
> -QEMU_VERSION = 9.0.2
> +QEMU_VERSION = 9.1.0
>  QEMU_SOURCE = qemu-$(QEMU_VERSION).tar.xz
>  QEMU_SITE = https://download.qemu.org
>  QEMU_SELINUX_MODULES = qemu virt
Waldemar Brodkorb Sept. 17, 2024, 8:08 a.m. UTC | #2
Hi Romain,
Romain Naour wrote,

> Hello Waldemar,
> 
> Le 15/09/2024 à 16:24, Waldemar Brodkorb a écrit :
> > See here for changes:
> > https://wiki.qemu.org/ChangeLog/9.1
> > 
> > The support for the nios2 architecture got removed.
> 
> How did you test this version bump?

Just manually.
 
> I would recommend to use gitlab-ci and push a branch with a specific name: <qemu
> version>-defconfigs-qemu (see [1][2][3]).
> 
> Note: With the gitlab-ci free tier (using shared gitlab-ci runners), defconfigs
> like the qemu_aarch64_sbsa_defconfig takes too long to build and reach the 6h
> job timeout or filesystem size limit.

Right, it seems the filesystem limit is reached on the
qemu_aarch64_sbsa_defconfig.

See here:
https://gitlab.com/wbx-github/buildroot/-/pipelines/1456175948

Otherwise it looks good after fixing the riscv qemu commandline
problem.

I will sent a new series.

Thanks for introducing the Gitlab testing to me.

best regards
 Waldemar
diff mbox series

Patch

diff --git a/package/qemu/Config.in b/package/qemu/Config.in
index 608e4d429d..2d15ab1ea9 100644
--- a/package/qemu/Config.in
+++ b/package/qemu/Config.in
@@ -252,11 +252,6 @@  config BR2_PACKAGE_QEMU_TARGET_MIPSN32EL
 	help
 	  MIPS N32 architecture, little-endian.
 
-config BR2_PACKAGE_QEMU_TARGET_NIOS2
-	bool "nios2"
-	help
-	  Nios II architecture.
-
 config BR2_PACKAGE_QEMU_TARGET_OR1K
 	bool "or1k"
 	select BR2_PACKAGE_QEMU_FDT if BR2_PACKAGE_QEMU_SYSTEM
diff --git a/package/qemu/Config.in.host b/package/qemu/Config.in.host
index 8dd0c7d11b..4db114490a 100644
--- a/package/qemu/Config.in.host
+++ b/package/qemu/Config.in.host
@@ -9,7 +9,6 @@  config BR2_PACKAGE_HOST_QEMU_ARCH_SUPPORTS
 	default y if BR2_microblazebe
 	default y if BR2_mips
 	default y if BR2_mipsel
-	default y if BR2_nios2
 	default y if BR2_or1k
 	default y if BR2_powerpc
 	default y if BR2_powerpc64
diff --git a/package/qemu/qemu.hash b/package/qemu/qemu.hash
index 419dd0d1b3..169fe05068 100644
--- a/package/qemu/qemu.hash
+++ b/package/qemu/qemu.hash
@@ -1,4 +1,4 @@ 
 # Locally computed, tarball verified with GPG signature
-sha256  a8c3f596aece96da3b00cafb74baafa0d14515eafb8ed1ee3f7f5c2d0ebf02b6  qemu-9.0.2.tar.xz
+sha256  816b7022a8ba7c2ac30e2e0cf973e826f6bcc8505339603212c5ede8e94d7834  qemu-9.1.0.tar.xz
 sha256  6f04ae8364d0079a192b14635f4b1da294ce18724c034c39a6a41d1b09df6100  COPYING
 sha256  dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  COPYING.LIB
diff --git a/package/qemu/qemu.mk b/package/qemu/qemu.mk
index 16cff13d18..e9f6520d89 100644
--- a/package/qemu/qemu.mk
+++ b/package/qemu/qemu.mk
@@ -6,7 +6,7 @@ 
 
 # When updating the version, check whether the list of supported targets
 # needs to be updated.
-QEMU_VERSION = 9.0.2
+QEMU_VERSION = 9.1.0
 QEMU_SOURCE = qemu-$(QEMU_VERSION).tar.xz
 QEMU_SITE = https://download.qemu.org
 QEMU_SELINUX_MODULES = qemu virt