diff mbox series

[next] package/nushell: update to 0.96.1

Message ID ZsNed1fYn9iJDyny@waldemar-brodkorb.de
State Accepted
Headers show
Series [next] package/nushell: update to 0.96.1 | expand

Commit Message

Waldemar Brodkorb Aug. 19, 2024, 3:02 p.m. UTC
For changes see the nushell blog:
https://www.nushell.sh/blog/

Broken since the update of rust in -next.
Patch for sparc64 no longer required.

Fixes:
 - http://autobuild.buildroot.org/results/f11/f11c62f504e9ce68ed9e3fb3533d53942cb87092

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
---
 .../0001-uucore-add-support-for-sparc64.patch | 59 -------------------
 package/nushell/nushell.hash                  |  2 +-
 package/nushell/nushell.mk                    |  9 +--
 3 files changed, 2 insertions(+), 68 deletions(-)
 delete mode 100644 package/nushell/0001-uucore-add-support-for-sparc64.patch
diff mbox series

Patch

diff --git a/package/nushell/0001-uucore-add-support-for-sparc64.patch b/package/nushell/0001-uucore-add-support-for-sparc64.patch
deleted file mode 100644
index ad7e70a56d..0000000000
--- a/package/nushell/0001-uucore-add-support-for-sparc64.patch
+++ /dev/null
@@ -1,59 +0,0 @@ 
-From 9f4330f94cc471d880df7d9089ee1105b27fd321 Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Sat, 6 Jan 2024 10:26:54 +0100
-Subject: [PATCH] uucore: add support for sparc64
-
-Add support for sparc64 in uucore to avoid the following build failure
-with nushell:
-
-error[E0308]: mismatched types
-   --> /home/autobuild/autobuild/instance-7/output-1/build/nushell-0.85.0/VENDOR/uucore/src/lib/features/fs.rs:121:16
-    |
-111 |     pub fn number_of_links(&self) -> u64 {
-    |                                      --- expected `u64` because of return type
-...
-121 |         return self.0.st_nlink;
-    |                ^^^^^^^^^^^^^^^ expected `u64`, found `u32`
-    |
-help: you can convert a `u32` to a `u64`
-    |
-121 |         return self.0.st_nlink.into();
-    |                               +++++++
-
-For more information about this error, try `rustc --explain E0308`.
-error: could not compile `uucore` (lib) due to previous error
-
-Fixes:
- - http://autobuild.buildroot.org/results/f9f0287a8e39c65895014ca513ed25071f020add
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Upstream: https://github.com/uutils/coreutils/commit/d158f1a396d19cc2aed68131b80ec3b7325d108e
-[Dario: make the patch to be applied with fuzz factor 0]
-Signed-off-by: Dario Binacchi <dario.binacchi@amarulasolutions.com>
----
- src/uucore/src/lib/features/fs.rs | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/VENDOR/uucore/src/lib/features/fs.rs b/VENDOR/uucore/src/lib/features/fs.rs
-index 20cc9e13d..3b9170bc3 100644
---- a/VENDOR/uucore/src/lib/features/fs.rs
-+++ b/VENDOR/uucore/src/lib/features/fs.rs
-@@ -116,6 +116,7 @@
-             not(target_os = "freebsd"),
-             not(target_arch = "aarch64"),
-             not(target_arch = "riscv64"),
-+            not(target_arch = "sparc64"),
-             target_pointer_width = "64"
-         ))]
-         return self.0.st_nlink;
-@@ -127,6 +128,7 @@
-                 target_os = "freebsd",
-                 target_arch = "aarch64",
-                 target_arch = "riscv64",
-+                target_arch = "sparc64",
-                 not(target_pointer_width = "64")
-             )
-         ))]
--- 
-2.43.0
-
diff --git a/package/nushell/nushell.hash b/package/nushell/nushell.hash
index c125a6c652..8336054455 100644
--- a/package/nushell/nushell.hash
+++ b/package/nushell/nushell.hash
@@ -1,3 +1,3 @@ 
 # Locally generated
-sha256  9175b7e25a93a35c4f2690a63e7c36ac2dc31a9d762f59de01aac8ac1075b02f  nushell-0.85.0-cargo2.tar.gz
+sha256  592f3b74156be0e65f8ef01fbc2e947480b91407190f93761d7c9531f381bfac  nushell-0.96.1-cargo2.tar.gz
 sha256  2dc1f03f729c21902d869b4d8f8dc528fc730f4c6ad83fc128672bda0ad69196  LICENSE
diff --git a/package/nushell/nushell.mk b/package/nushell/nushell.mk
index 7b538da4e2..a05eaa9829 100644
--- a/package/nushell/nushell.mk
+++ b/package/nushell/nushell.mk
@@ -4,19 +4,12 @@ 
 #
 ################################################################################
 
-NUSHELL_VERSION = 0.85.0
+NUSHELL_VERSION = 0.96.1
 NUSHELL_SITE = $(call github,nushell,nushell,$(NUSHELL_VERSION))
 NUSHELL_LICENSE = MIT
 NUSHELL_LICENSE_FILES = LICENSE
 NUSHELL_DEPENDENCIES = host-pkgconf openssl ncurses
 
-# 0001-uucore-add-support-for-sparc64.patch
-define NUSHELL_PATCH_CHECKSUM_FILE
-	$(SED) 's/b0390ae7bca8b31f0db289a5d064bba36d45e4d137674e9df2c6ab6256f926f4/f8ce2ad571e1482f6833cb147eafeb724776e7887ebabf339a5f3e79860583cb/' \
-		$(@D)/VENDOR/uucore/.cargo-checksum.json
-endef
-NUSHELL_POST_PATCH_HOOKS += NUSHELL_PATCH_CHECKSUM_FILE
-
 # Add /usr/bin/nu to /etc/shells as in package/bash/bash.mk
 define NUSHELL_ADD_NU_TO_SHELLS
 	grep -qsE '^/usr/bin/nu$$' $(TARGET_DIR)/etc/shells \