diff mbox series

[v2] package/libjcat: fix linking, add missing intl library

Message ID ZrNtL/si1xlTqM46@waldemar-brodkorb.de
State Accepted
Headers show
Series [v2] package/libjcat: fix linking, add missing intl library | expand

Commit Message

Waldemar Brodkorb Aug. 7, 2024, 12:48 p.m. UTC
For musl/uClibc-ng toolchains we need to explicitely link
libintl. The problem exist since the addition of the package
in commit e52605c092d8eaa926da8720ae498a38eddb5205.

Fixes:
 - http://autobuild.buildroot.net/results/58c/58c7ecbcfab96ebbc7a20291d4712cf64094b9f7/
 - http://autobuild.buildroot.net/results/5d7/5d7c5dea0213f5a24489c397c5703c0601b2f12d/

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
---
v1->v2:
 - use $(TARGET_NLS_LIBS) / $(TARGET_NLS_DEPENDENCIES) for more
   correctness (suggested by Thomas P.)

I only tested a minimal musl toolchain this time, but I think it
should work for uClibc-ng, too. 
---
 package/libjcat/libjcat.mk | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni Aug. 7, 2024, 7:41 p.m. UTC | #1
On Wed, 7 Aug 2024 14:48:47 +0200
Waldemar Brodkorb <wbx@openadk.org> wrote:

> For musl/uClibc-ng toolchains we need to explicitely link
> libintl. The problem exist since the addition of the package
> in commit e52605c092d8eaa926da8720ae498a38eddb5205.
> 
> Fixes:
>  - http://autobuild.buildroot.net/results/58c/58c7ecbcfab96ebbc7a20291d4712cf64094b9f7/
>  - http://autobuild.buildroot.net/results/5d7/5d7c5dea0213f5a24489c397c5703c0601b2f12d/
> 
> Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
> ---
> v1->v2:
>  - use $(TARGET_NLS_LIBS) / $(TARGET_NLS_DEPENDENCIES) for more
>    correctness (suggested by Thomas P.)

Thanks for the v2, applied to master, thanks!

Thomas
diff mbox series

Patch

diff --git a/package/libjcat/libjcat.mk b/package/libjcat/libjcat.mk
index e13e5dbfb7..c365c1914b 100644
--- a/package/libjcat/libjcat.mk
+++ b/package/libjcat/libjcat.mk
@@ -10,7 +10,9 @@  LIBJCAT_SOURCE = libjcat-$(LIBJCAT_VERSION).tar.xz
 LIBJCAT_LICENSE = LGPL-2.1+
 LIBJCAT_LICENSE_FILES = LICENSE
 LIBJCAT_INSTALL_STAGING = YES
-LIBJCAT_DEPENDENCIES = host-pkgconf json-glib libglib2
+LIBJCAT_DEPENDENCIES = host-pkgconf json-glib libglib2 $(TARGET_NLS_DEPENDENCIES)
+
+LIBJCAT_LDFLAGS = $(TARGET_NLS_LIBS)
 
 LIBJCAT_CONF_OPTS = \
 	-Dgtkdoc=false \