diff mbox series

package/fluent-bit: fix issue with uClibc-ng toolchains

Message ID ZrBtHPY63Wyfy++l@waldemar-brodkorb.de
State Changes Requested
Headers show
Series package/fluent-bit: fix issue with uClibc-ng toolchains | expand

Commit Message

Waldemar Brodkorb Aug. 5, 2024, 6:11 a.m. UTC
When SSP in the toolchain is disabled, the compilation will
fail. So handle the situation for SSP enabled and disabled
toolchains.

Fixes:
 - http://autobuild.buildroot.net/results/c9e/c9ed27a51a68429b2ed2d8eebb1afc919ecbead1/

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
---
 package/fluent-bit/fluent-bit.mk | 8 ++++++++
 1 file changed, 8 insertions(+)

Comments

Thomas Petazzoni Aug. 5, 2024, 6:55 a.m. UTC | #1
Hello Waldemar,

On Mon, 5 Aug 2024 08:11:40 +0200
Waldemar Brodkorb <wbx@openadk.org> wrote:

> +ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
> +ifeq ($(BR2_TOOLCHAIN_BUILDROOT_USE_SSP),y)

BR2_TOOLCHAIN_BUILDROOT_USE_SSP only makes sense for internal
toolchains, so that wouldn't do what's expected for external
toolchains. Also putting this inside a uClibc conditional doesn't make
sense, the SSP option is independent from the C library.

But overall, you should just unconditionally pass -DFLB_SECURITY=No,
and let Buildroot decide which security hardening features to enable.

Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/fluent-bit/fluent-bit.mk b/package/fluent-bit/fluent-bit.mk
index 5463682e45..a744a61c9b 100644
--- a/package/fluent-bit/fluent-bit.mk
+++ b/package/fluent-bit/fluent-bit.mk
@@ -20,6 +20,14 @@  FLUENT_BIT_CONF_OPTS += \
 	-DFLB_PREFER_SYSTEM_LIBS=Yes \
 	-DFLB_BACKTRACE=No
 
+ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT_USE_SSP),y)
+FLUENT_BIT_CONF_OPTS += -DFLB_SECURITY=Yes
+else
+FLUENT_BIT_CONF_OPTS += -DFLB_SECURITY=No
+endif
+endif
+
 ifeq ($(BR2_PACKAGE_FLUENT_BIT_WASM),y)
 FLUENT_BIT_WAMR_ARCH = $(call qstrip,$(BR2_PACKAGE_FLUENT_BIT_WASM_ARCH))