diff mbox series

package/ffmpeg: fix microblaze compile issue

Message ID Zr3cWSzM+spo0TNf@waldemar-brodkorb.de
State Accepted
Headers show
Series package/ffmpeg: fix microblaze compile issue | expand

Commit Message

Waldemar Brodkorb Aug. 15, 2024, 10:45 a.m. UTC
Since the update of ffmpeg to 6.1.1 in commit
fa36a6375dbeae131c596070570cec66c7bd2456 there are
a lot of microblaze build failures.

The compilation failure is triggered by GCC Bug 68485.

Fixes:
 - http://autobuild.buildroot.net/results/524/524cef193aec30471e55eb0eecfa39f0d6011a91

And many more.

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
---
 package/ffmpeg/ffmpeg.mk | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Thomas Petazzoni Aug. 15, 2024, 12:50 p.m. UTC | #1
On Thu, 15 Aug 2024 12:45:45 +0200
Waldemar Brodkorb <wbx@openadk.org> wrote:

> +ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_68485),y)
> +FFMPEG_CONF_OPTS += --disable-optimizations
> +FFMPEG_CFLAGS += -O0
> +endif

Could you clarify why both --disable-optimizations and -O0 are needed?

Thanks!

Thomas
Waldemar Brodkorb Aug. 15, 2024, 2:15 p.m. UTC | #2
Hi Thomas,
Thomas Petazzoni wrote,

> On Thu, 15 Aug 2024 12:45:45 +0200
> Waldemar Brodkorb <wbx@openadk.org> wrote:
> 
> > +ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_68485),y)
> > +FFMPEG_CONF_OPTS += --disable-optimizations
> > +FFMPEG_CFLAGS += -O0
> > +endif
> 
> Could you clarify why both --disable-optimizations and -O0 are needed?

Yes, --disable-optimization prevents adding -O3 after our CFLAGS.
So indeed both things are required to complete the build.

best regards
 Waldemar
Yann E. MORIN Aug. 15, 2024, 7:49 p.m. UTC | #3
Waldemar, All,

On 2024-08-15 12:45 +0200, Waldemar Brodkorb spake thusly:
> Since the update of ffmpeg to 6.1.1 in commit
> fa36a6375dbeae131c596070570cec66c7bd2456 there are
> a lot of microblaze build failures.
> 
> The compilation failure is triggered by GCC Bug 68485.

I added a little blurb with your explanations why --disable-optimizations
was also needed.

> Fixes:
>  - http://autobuild.buildroot.net/results/524/524cef193aec30471e55eb0eecfa39f0d6011a91
> 
> And many more.
> 
> Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/ffmpeg/ffmpeg.mk | 5 +++++
>  1 file changed, 5 insertions(+)
> 
> diff --git a/package/ffmpeg/ffmpeg.mk b/package/ffmpeg/ffmpeg.mk
> index 19c270a14b..a010c0168c 100644
> --- a/package/ffmpeg/ffmpeg.mk
> +++ b/package/ffmpeg/ffmpeg.mk
> @@ -557,6 +557,11 @@ FFMPEG_CONF_OPTS += --disable-optimizations
>  FFMPEG_CFLAGS += -O0
>  endif
>  
> +ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_68485),y)
> +FFMPEG_CONF_OPTS += --disable-optimizations
> +FFMPEG_CFLAGS += -O0
> +endif
> +
>  ifeq ($(BR2_ARM_INSTRUCTIONS_THUMB),y)
>  FFMPEG_CFLAGS += -marm
>  endif
> -- 
> 2.39.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/ffmpeg/ffmpeg.mk b/package/ffmpeg/ffmpeg.mk
index 19c270a14b..a010c0168c 100644
--- a/package/ffmpeg/ffmpeg.mk
+++ b/package/ffmpeg/ffmpeg.mk
@@ -557,6 +557,11 @@  FFMPEG_CONF_OPTS += --disable-optimizations
 FFMPEG_CFLAGS += -O0
 endif
 
+ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_68485),y)
+FFMPEG_CONF_OPTS += --disable-optimizations
+FFMPEG_CFLAGS += -O0
+endif
+
 ifeq ($(BR2_ARM_INSTRUCTIONS_THUMB),y)
 FFMPEG_CFLAGS += -marm
 endif