@@ -131,6 +131,11 @@ define BUSYBOX_DISABLE_MMU_APPLETS
$(call KCONFIG_DISABLE_OPT,CONFIG_SWAPONOFF,$(BUSYBOX_BUILD_CONFIG))
$(call KCONFIG_DISABLE_OPT,CONFIG_ASH,$(BUSYBOX_BUILD_CONFIG))
$(call KCONFIG_ENABLE_OPT,CONFIG_HUSH,$(BUSYBOX_BUILD_CONFIG))
+ $(call KCONFIG_ENABLE_OPT,CONFIG_HUSH_IF,$(BUSYBOX_BUILD_CONFIG))
+ $(call KCONFIG_ENABLE_OPT,CONFIG_HUSH_LOOPS,$(BUSYBOX_BUILD_CONFIG))
+ $(call KCONFIG_ENABLE_OPT,CONFIG_HUSH_CASE,$(BUSYBOX_BUILD_CONFIG))
+ $(call KCONFIG_ENABLE_OPT,CONFIG_HUSH_FUNCTIONS,$(BUSYBOX_BUILD_CONFIG))
+ $(call KCONFIG_ENABLE_OPT,CONFIG_HUSH_INTERACTIVE,$(BUSYBOX_BUILD_CONFIG))
endef
endif
Our default Busybox configuration enables the ash shell, but since this shell doesn't work on noMMU platforms, we enable the hush shell instead. However, the hush shell by itself isn't very useful without interactive mode, support for loops, if and case statements, etc. So we enable them. The drawback of this method is that those options are forcefully selected, regarless of the users choices. The other solution would be to have a separate Busybox configuration for noMMU platforms, or work with fragments of Busybox configurations. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> --- package/busybox/busybox.mk | 5 +++++ 1 files changed, 5 insertions(+), 0 deletions(-)