diff mbox

wine: Add OpenAL dependency

Message ID 566E05D1.700@dawncrow.de
State Accepted
Headers show

Commit Message

André Zwing Dec. 13, 2015, 11:57 p.m. UTC
Signed-off-by: André Hentschel <nerv@dawncrow.de>
---
 package/wine/wine.mk | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni Dec. 15, 2015, 9:57 p.m. UTC | #1
Dear André Hentschel,

On Mon, 14 Dec 2015 00:57:05 +0100, André Hentschel wrote:
> Signed-off-by: André Hentschel <nerv@dawncrow.de>
> ---
>  package/wine/wine.mk | 8 +++++++-
>  1 file changed, 7 insertions(+), 1 deletion(-)

Applied, thanks.

Thomas
diff mbox

Patch

diff --git a/package/wine/wine.mk b/package/wine/wine.mk
index 1a1fea0..98958ef 100644
--- a/package/wine/wine.mk
+++ b/package/wine/wine.mk
@@ -25,7 +25,6 @@  WINE_CONF_OPTS = \
 	--without-gphoto \
 	--without-gsm \
 	--without-hal \
-	--without-openal \
 	--without-opencl \
 	--without-oss
 
@@ -163,6 +162,13 @@  else
 WINE_CONF_OPTS += --without-curses
 endif
 
+ifeq ($(BR2_PACKAGE_OPENAL),y)
+WINE_CONF_OPTS += --with-openal
+WINE_DEPENDENCIES += openal
+else
+WINE_CONF_OPTS += --without-openal
+endif
+
 ifeq ($(BR2_PACKAGE_OPENLDAP),y)
 WINE_CONF_OPTS += --with-ldap
 WINE_DEPENDENCIES += openldap