diff mbox

[v4] wine: Add gettext dependency for host-wine

Message ID 55056E86.5020109@dawncrow.de
State Accepted
Headers show

Commit Message

André Zwing March 15, 2015, 11:35 a.m. UTC
Mostly based on a comment by Yann E. MORIN

Signed-off-by: André Hentschel <nerv@dawncrow.de>
Cc: Yann E. MORIN <yann.morin.1998@free.fr>
---
 package/wine/wine.mk | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

Comments

Yann E. MORIN March 15, 2015, 4:05 p.m. UTC | #1
Andé, All,

On 2015-03-15 12:35 +0100, André Hentschel spake thusly:
> Mostly based on a comment by Yann E. MORIN
> 
> Signed-off-by: André Hentschel <nerv@dawncrow.de>
> Cc: Yann E. MORIN <yann.morin.1998@free.fr>
> ---
>  package/wine/wine.mk | 6 ++++--
>  1 file changed, 4 insertions(+), 2 deletions(-)
> 
> diff --git a/package/wine/wine.mk b/package/wine/wine.mk
> index aa474f9..a699fff 100644
> --- a/package/wine/wine.mk
> +++ b/package/wine/wine.mk
> @@ -243,6 +243,10 @@ else
>  WINE_CONF_OPTS += --without-zlib
>  endif
>  
> +# host-gettext is essential for .po file support in host-wine wrc
> +HOST_WINE_DEPENDENCIES += host-gettext
> +HOST_WINE_CONF_OPTS += --with-gettext --with-gettextpo

How can I test that?

I mean, I have no x86 target (for now), so how can I check that this
patch does produce the expected output?

Regards,
Yann E. MORIN.

>  # Wine needs to enable 64-bit build tools on 64-bit host
>  ifeq ($(HOSTARCH),x86_64)
>  HOST_WINE_CONF_OPTS += --enable-win64
> @@ -280,8 +284,6 @@ HOST_WINE_CONF_OPTS += \
>  	--without-curses \
>  	--without-dbus \
>  	--without-fontconfig \
> -	--without-gettext \
> -	--without-gettextpo \
>  	--without-gphoto \
>  	--without-glu \
>  	--without-gnutls \
> -- 
> 1.9.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Yann E. MORIN March 15, 2015, 10:47 p.m. UTC | #2
André, All,

On 2015-03-15 12:35 +0100, André Hentschel spake thusly:
> Mostly based on a comment by Yann E. MORIN
> 
> Signed-off-by: André Hentschel <nerv@dawncrow.de>
> Cc: Yann E. MORIN <yann.morin.1998@free.fr>

Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
[tested by running readelf on 'wrc' and checking it is now linked
 with libgettextpo.so.0]
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>

Regards,
Yann E. MORIN.

> ---
>  package/wine/wine.mk | 6 ++++--
>  1 file changed, 4 insertions(+), 2 deletions(-)
> 
> diff --git a/package/wine/wine.mk b/package/wine/wine.mk
> index aa474f9..a699fff 100644
> --- a/package/wine/wine.mk
> +++ b/package/wine/wine.mk
> @@ -243,6 +243,10 @@ else
>  WINE_CONF_OPTS += --without-zlib
>  endif
>  
> +# host-gettext is essential for .po file support in host-wine wrc
> +HOST_WINE_DEPENDENCIES += host-gettext
> +HOST_WINE_CONF_OPTS += --with-gettext --with-gettextpo
> +
>  # Wine needs to enable 64-bit build tools on 64-bit host
>  ifeq ($(HOSTARCH),x86_64)
>  HOST_WINE_CONF_OPTS += --enable-win64
> @@ -280,8 +284,6 @@ HOST_WINE_CONF_OPTS += \
>  	--without-curses \
>  	--without-dbus \
>  	--without-fontconfig \
> -	--without-gettext \
> -	--without-gettextpo \
>  	--without-gphoto \
>  	--without-glu \
>  	--without-gnutls \
> -- 
> 1.9.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Thomas Petazzoni March 16, 2015, 9:08 p.m. UTC | #3
Dear André Hentschel,

On Sun, 15 Mar 2015 12:35:34 +0100, André Hentschel wrote:
> Mostly based on a comment by Yann E. MORIN
> 
> Signed-off-by: André Hentschel <nerv@dawncrow.de>
> Cc: Yann E. MORIN <yann.morin.1998@free.fr>

Applied, thanks.

Thomas
diff mbox

Patch

diff --git a/package/wine/wine.mk b/package/wine/wine.mk
index aa474f9..a699fff 100644
--- a/package/wine/wine.mk
+++ b/package/wine/wine.mk
@@ -243,6 +243,10 @@  else
 WINE_CONF_OPTS += --without-zlib
 endif
 
+# host-gettext is essential for .po file support in host-wine wrc
+HOST_WINE_DEPENDENCIES += host-gettext
+HOST_WINE_CONF_OPTS += --with-gettext --with-gettextpo
+
 # Wine needs to enable 64-bit build tools on 64-bit host
 ifeq ($(HOSTARCH),x86_64)
 HOST_WINE_CONF_OPTS += --enable-win64
@@ -280,8 +284,6 @@  HOST_WINE_CONF_OPTS += \
 	--without-curses \
 	--without-dbus \
 	--without-fontconfig \
-	--without-gettext \
-	--without-gettextpo \
 	--without-gphoto \
 	--without-glu \
 	--without-gnutls \