diff mbox

[2/2] wine: Add gettext dependency check for host-wine

Message ID 54FB0CA8.10001@dawncrow.de
State Superseded
Headers show

Commit Message

André Zwing March 7, 2015, 2:35 p.m. UTC
Signed-off-by: André Hentschel <nerv@dawncrow.de>
---

 package/wine/wine.mk | 9 +++++++--
 1 file changed, 7 insertions(+), 2 deletions(-)
diff mbox

Patch

diff --git a/package/wine/wine.mk b/package/wine/wine.mk
index e931c87..9c6e2aa 100644
--- a/package/wine/wine.mk
+++ b/package/wine/wine.mk
@@ -237,6 +237,13 @@  else
 WINE_CONF_OPTS += --without-zlib
 endif
 
+ifeq ($(BR2_PACKAGE_GETTEXT),y)
+HOST_WINE_CONF_OPTS += --with-gettext --with-gettextpo
+WINE_DEPENDENCIES += gettext
+else
+HOST_WINE_CONF_OPTS += --without-gettext --without-gettextpo
+endif
+
 # Wine needs to enable 64-bit build tools on 64-bit host
 ifeq ($(HOSTARCH),x86_64)
 HOST_WINE_CONF_OPTS += --enable-win64
@@ -274,8 +281,6 @@  HOST_WINE_CONF_OPTS += \
        --without-curses \
        --without-dbus \
        --without-fontconfig \
-       --without-gettext \
-       --without-gettextpo \
        --without-gphoto \
        --without-glu \
        --without-gnutls \