diff mbox

wine: Add dependency check for ALSA

Message ID 54F8B0C0.2040806@dawncrow.de
State Accepted
Headers show

Commit Message

André Zwing March 5, 2015, 7:38 p.m. UTC
Signed-off-by: André Hentschel <nerv@dawncrow.de>
---

This fixes the problem from http://autobuild.buildroot.org/results/018/018391c5e70d33bc0b5745ad7a2a273efa9be0d7/

 package/wine/wine.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Ryan Barnett March 5, 2015, 8:11 p.m. UTC | #1
André ,

On Thu, Mar 5, 2015 at 1:38 PM, André Hentschel <nerv@dawncrow.de> wrote:

You should move the fixes line above your signed off line as follows
otherwise it will not be preserved in the commit message:

Fixes:
  http://autobuild.buildroot.org/results/018/018391c5e70d33bc0b5745ad7a2a273efa9be0d7/

> Signed-off-by: André Hentschel <nerv@dawncrow.de>
> ---
>
> This fixes the problem from http://autobuild.buildroot.org/results/018/018391c5e70d33bc0b5745ad7a2a273efa9be0d7/
>
>  package/wine/wine.mk | 7 +++++++
>  1 file changed, 7 insertions(+)

Thanks,
-Ryan
Thomas Petazzoni March 5, 2015, 8:19 p.m. UTC | #2
Dear André Hentschel,

On Thu, 05 Mar 2015 20:38:40 +0100, André Hentschel wrote:
> Signed-off-by: André Hentschel <nerv@dawncrow.de>

Thanks, applied, after moving the reference to the autobuilder failure
within the commit log itself, as suggested by Ryan.

Thanks,

Thomas
diff mbox

Patch

diff --git a/package/wine/wine.mk b/package/wine/wine.mk
index 926ac99..47c7259 100644
--- a/package/wine/wine.mk
+++ b/package/wine/wine.mk
@@ -29,6 +29,13 @@  ifeq ($(BR2_TOOLCHAIN_EXTERNAL),y)
 WINE_CONF_OPTS += TARGETFLAGS="-b $(call qstrip,$(BR2_TOOLCHAIN_EXTERNAL_PREFIX))"
 endif
 
+ifeq ($(BR2_PACKAGE_ALSA_LIB)$(BR2_PACKAGE_ALSA_LIB_SEQ),yy)
+WINE_CONF_OPTS += --with-alsa
+WINE_DEPENDENCIES += alsa-lib
+else
+WINE_CONF_OPTS += --without-alsa
+endif
+
 ifeq ($(BR2_PACKAGE_CUPS),y)
 WINE_CONF_OPTS += --with-cups
 WINE_DEPENDENCIES += cups