diff mbox series

[1/1] package/proftpd: fix group name preventing server from starting

Message ID 4243551.mvXUDI8C0e@localhost
State Accepted
Headers show
Series [1/1] package/proftpd: fix group name preventing server from starting | expand

Commit Message

Mattia Narducci Aug. 24, 2024, 4:43 p.m. UTC
Replace the group name 'nogroup' with 'nobody' in the default ProFTPD
configuration file. This fixes the following error when starting the
server:

  proftpd[110]: fatal: Group: Unknown group 'nogroup' on line 30 of '/etc/proftpd.conf'

Fixes: 0d887cc2b4 ("system: replace nogroup with nobody")
Signed-off-by: Mattia Narducci <mattianarducci1@gmail.com>
---
 package/proftpd/proftpd.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Peter Korsgaard Aug. 26, 2024, 8:05 a.m. UTC | #1
>>>>> "Mattia" == Mattia Narducci <mattianarducci1@gmail.com> writes:

 > Replace the group name 'nogroup' with 'nobody' in the default ProFTPD
 > configuration file. This fixes the following error when starting the
 > server:

 >   proftpd[110]: fatal: Group: Unknown group 'nogroup' on line 30 of '/etc/proftpd.conf'

 > Fixes: 0d887cc2b4 ("system: replace nogroup with nobody")
 > Signed-off-by: Mattia Narducci <mattianarducci1@gmail.com>

Committed, thanks.
Peter Korsgaard Sept. 18, 2024, 5:08 p.m. UTC | #2
>>>>> "Mattia" == Mattia Narducci <mattianarducci1@gmail.com> writes:

 > Replace the group name 'nogroup' with 'nobody' in the default ProFTPD
 > configuration file. This fixes the following error when starting the
 > server:

 >   proftpd[110]: fatal: Group: Unknown group 'nogroup' on line 30 of '/etc/proftpd.conf'

 > Fixes: 0d887cc2b4 ("system: replace nogroup with nobody")
 > Signed-off-by: Mattia Narducci <mattianarducci1@gmail.com>

Committed to 2024.02.x, thanks.
diff mbox series

Patch

diff --git a/package/proftpd/proftpd.mk b/package/proftpd/proftpd.mk
index cd7d232672..72a0fe9354 100644
--- a/package/proftpd/proftpd.mk
+++ b/package/proftpd/proftpd.mk
@@ -130,6 +130,7 @@  endif
 define PROFTPD_INSTALL_TARGET_CMDS
 	$(INSTALL) -D -m 0755 $(@D)/proftpd $(TARGET_DIR)/usr/sbin/proftpd
 	$(INSTALL) -m 0644 -D $(@D)/sample-configurations/basic.conf $(TARGET_DIR)/etc/proftpd.conf
+	$(SED) 's/^\(Group\s\+\)nogroup/\1nobody/' $(TARGET_DIR)/etc/proftpd.conf
 	$(PROFTPD_INSTALL_FTPQUOTA)
 	$(PROFTPD_INSTALL_FTPASSWD)
 endef