diff mbox series

[1/1] package/python-pysnmp: use poetry setup type

Message ID 20241105181420.1423251-1-james.hilliard1@gmail.com
State Accepted
Headers show
Series [1/1] package/python-pysnmp: use poetry setup type | expand

Commit Message

James Hilliard Nov. 5, 2024, 6:14 p.m. UTC
Use the new poetry setup type which automatically pulls in the
host-python-poetry-core dependency.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/python-pysnmp/python-pysnmp.mk | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

Comments

Thomas Petazzoni Nov. 6, 2024, 10:27 p.m. UTC | #1
On Tue,  5 Nov 2024 11:14:20 -0700
James Hilliard <james.hilliard1@gmail.com> wrote:

> Use the new poetry setup type which automatically pulls in the
> host-python-poetry-core dependency.
> 
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
> ---
>  package/python-pysnmp/python-pysnmp.mk | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/python-pysnmp/python-pysnmp.mk b/package/python-pysnmp/python-pysnmp.mk
index eac01b3169..2703833ffa 100644
--- a/package/python-pysnmp/python-pysnmp.mk
+++ b/package/python-pysnmp/python-pysnmp.mk
@@ -7,9 +7,8 @@ 
 PYTHON_PYSNMP_VERSION = 7.1.8
 PYTHON_PYSNMP_SOURCE = pysnmp-$(PYTHON_PYSNMP_VERSION).tar.gz
 PYTHON_PYSNMP_SITE = https://files.pythonhosted.org/packages/e9/af/f9e379bd9e607fd289b6cef13d633667c4d213f8c1519a86f61eed09731f
-PYTHON_PYSNMP_SETUP_TYPE = pep517
+PYTHON_PYSNMP_SETUP_TYPE = poetry
 PYTHON_PYSNMP_LICENSE = BSD-2-Clause
 PYTHON_PYSNMP_LICENSE_FILES = LICENSE.rst
-PYTHON_PYSNMP_DEPENDENCIES = host-python-poetry-core
 
 $(eval $(python-package))