diff mbox series

[1/1] package/opkg: fix --without-xattr configure option typo

Message ID 20241104211157.639393-1-ju.o@free.fr
State New
Headers show
Series [1/1] package/opkg: fix --without-xattr configure option typo | expand

Commit Message

Julien Olivain Nov. 4, 2024, 9:11 p.m. UTC
Commit efe93b34e "package/opkg: bump to version 0.7.0" [1] introduced
a use of --without-xattrs (with an extra 's') configure option.

When compiling opkg, the configure step show the warning:

    configure: WARNING: unrecognized options: ... --without-xattrs

The actual option name is "--without-xattr" (without an extra 's').
See [2].

This commit fixes the typo.

[1] https://gitlab.com/buildroot.org/buildroot/-/commit/efe93b34ec678c0d35b2ec062128fccf55912b8e
[2] https://git.yoctoproject.org/opkg/tree/configure.ac?h=v0.7.0#n167

Signed-off-by: Julien Olivain <ju.o@free.fr>
---
 package/opkg/opkg.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/package/opkg/opkg.mk b/package/opkg/opkg.mk
index 0323a49f0b..4922d8fc0f 100644
--- a/package/opkg/opkg.mk
+++ b/package/opkg/opkg.mk
@@ -13,7 +13,7 @@  OPKG_INSTALL_STAGING = YES
 OPKG_CONF_OPTS = \
 	--enable-sha256 \
 	--without-acl \
-	--without-xattrs
+	--without-xattr
 
 ifeq ($(BR2_PACKAGE_OPKG_GPG_SIGN),y)
 OPKG_CONF_OPTS += --enable-gpg