@@ -3308,6 +3308,7 @@ F: configs/ts5500_defconfig
N: Vladimir Oltean <olteanv@gmail.com>
F: package/qoriq-ddr-phy-binary/
F: package/qoriq-mc-binary/
+F: package/qoriq-mc-utils/
N: Volkov Viacheslav <sv99@inbox.ru>
F: package/v4l2grab/
@@ -457,6 +457,7 @@ menu "Firmware"
source "package/qoriq-ddr-phy-binary/Config.in"
source "package/qoriq-fm-ucode/Config.in"
source "package/qoriq-mc-binary/Config.in"
+ source "package/qoriq-mc-utils/Config.in"
source "package/rcw-smarc-sal28/Config.in"
source "package/rpi-firmware/Config.in"
source "package/sunxi-boards/Config.in"
new file mode 100644
@@ -0,0 +1,35 @@
+config BR2_PACKAGE_QORIQ_MC_UTILS
+ bool "qoriq-mc-utils"
+ help
+ The Management Complex (MC) is a key component of the networking
+ subsystem named DPAA2 (Data Path Acceleration Architecture, second
+ version) in some NXP Layerscape SoCs.
+
+ The MC firmware is configured through two distinct files named DPL
+ and DPC, which are customizable by the end user. Example
+ configuration files for NXP reference boards are distributed through
+ this package, and are frequently patched to produce the configuration
+ required in other scenarios.
+
+ https://github.com/nxp-qoriq/mc-utils
+ https://www.nxp.com/webapp/Download?colCode=DPAA2UM # sign in required
+
+if BR2_PACKAGE_QORIQ_MC_UTILS
+
+config BR2_PACKAGE_QORIQ_MC_UTILS_DPC
+ string "Data Path Configuration (DPC) file"
+ help
+ The DPC file contains the settings defining the behavior of the MC
+ firmware. Its source code follows the device tree syntax and is
+ compiled to a device tree blob, which is the file that must be
+ specified here.
+
+config BR2_PACKAGE_QORIQ_MC_UTILS_DPL
+ string "Data Path Layout (DPL) file"
+ help
+ The DPL file contains a description of the initial networking objects
+ created by the MC firmware when it boots. Its source code follows the
+ device tree syntax and is compiled to a device tree blob, which is
+ the file that must be specified here.
+
+endif
new file mode 100644
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256 1d3f4a6b2661cff9cfb5d4fcba3b181eb6febdd88a127fa069e306f51d778fc5 qoriq-mc-utils-10.39.0.tar.gz
+sha256 7a223031d76339df0e4e5a94d193a270fb9963d42b577aa42fe130a4657f3e17 LICENSE
new file mode 100644
@@ -0,0 +1,22 @@
+################################################################################
+#
+# qoriq-mc-utils
+#
+################################################################################
+
+QORIQ_MC_UTILS_VERSION = 10.39.0
+QORIQ_MC_UTILS_SITE = $(call github,nxp-qoriq,mc-utils,mc_release_$(QORIQ_MC_UTILS_VERSION))
+QORIQ_MC_UTILS_LICENSE = BSD-3-Clause
+QORIQ_MC_UTILS_INSTALL_IMAGES = YES
+QORIQ_MC_UTILS_INSTALL_TARGET = NO
+
+define QORIQ_MC_UTILS_BUILD_CMDS
+ $(MAKE) -C $(@D)/config/
+endef
+
+define QORIQ_MC_UTILS_INSTALL_IMAGES_CMDS
+ $(INSTALL) -D $(@D)/config/$(call qstrip,$(BR2_PACKAGE_QORIQ_MC_UTILS_DPC)) $(BINARIES_DIR)/dpc.dtb
+ $(INSTALL) -D $(@D)/config/$(call qstrip,$(BR2_PACKAGE_QORIQ_MC_UTILS_DPL)) $(BINARIES_DIR)/dpl.dtb
+endef
+
+$(eval $(generic-package))
The configuration files for the MC firmware binary are distributed through a separate repository on GitHub, and need a different package. They are licensed differently than the firmware itself, and unlike the firmware, they are customizable. Signed-off-by: Vladimir Oltean <olteanv@gmail.com> --- DEVELOPERS | 1 + package/Config.in | 1 + package/qoriq-mc-utils/Config.in | 35 ++++++++++++++++++++++ package/qoriq-mc-utils/qoriq-mc-utils.hash | 3 ++ package/qoriq-mc-utils/qoriq-mc-utils.mk | 22 ++++++++++++++ 5 files changed, 62 insertions(+) create mode 100644 package/qoriq-mc-utils/Config.in create mode 100644 package/qoriq-mc-utils/qoriq-mc-utils.hash create mode 100644 package/qoriq-mc-utils/qoriq-mc-utils.mk