deleted file mode 100644
@@ -1,45 +0,0 @@
-From 107efb2f1a014c4475e122677faddbe0dbef1000 Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Tue, 23 Jul 2024 14:54:59 +0200
-Subject: [PATCH] add stack-protector option
-
-Allow the user to disable stack-protector as it is not supported by all
-toolchains
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Upstream: https://gitlab.gnome.org/GNOME/libdex/-/commit/a65d33aebbe43024a046b3f3cc4a1c6c533838d0
----
- meson.build | 2 +-
- meson_options.txt | 3 +++
- 2 files changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/meson.build b/meson.build
-index d0ca81d..2f7aac2 100644
---- a/meson.build
-+++ b/meson.build
-@@ -126,7 +126,7 @@ test_c_args = [
- ['-Werror=format-security', '-Werror=format=2'],
- '-FImsvc_recommended_pragmas.h',
- ]
--if get_option('buildtype') != 'plain'
-+if get_option('buildtype') != 'plain' and get_option('stack-protector')
- if host_machine.system() != 'windows'
- test_c_args += '-fstack-protector-strong'
- endif
-diff --git a/meson_options.txt b/meson_options.txt
-index 519cd97..9e3364a 100644
---- a/meson_options.txt
-+++ b/meson_options.txt
-@@ -4,6 +4,9 @@ option('docs',
- option('examples',
- type: 'boolean', value: true,
- description: 'Build example programs')
-+option('stack-protector',
-+ type: 'boolean', value: true,
-+ description: 'Enable stack-protector')
- option('vapi',
- type: 'boolean', value: true,
- description: 'Generate vapi data (requires vapigen)')
-GitLab
-
@@ -1,5 +1,5 @@
-# From https://download.gnome.org/sources/libdex/0.6/libdex-0.6.1.sha256sum
-sha256 d176de6578571e32a8c0b603b6a5a13fa5f87fb6b5442575b38ec5af16b17a92 libdex-0.6.1.tar.xz
+# From https://download.gnome.org/sources/libdex/0.8/libdex-0.8.0.sha256sum
+sha256 659ab5d0eb7f10bd36af0cde08055158987690b9714e7f5b001c788ec1d01a25 libdex-0.8.0.tar.xz
# License files
sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551 COPYING
@@ -4,8 +4,9 @@
#
################################################################################
-LIBDEX_VERSION_MAJOR = 0.6
-LIBDEX_VERSION = $(LIBDEX_VERSION_MAJOR).1
+# The middle number is even for stable releases, odd for development ones.
+LIBDEX_VERSION_MAJOR = 0.8
+LIBDEX_VERSION = $(LIBDEX_VERSION_MAJOR).0
LIBDEX_SOURCE = libdex-$(LIBDEX_VERSION).tar.xz
LIBDEX_SITE = https://download.gnome.org/sources/libdex/$(LIBDEX_VERSION_MAJOR)
LIBDEX_LICENSE = LGPL-2.1+
Drop patch "0001-add-stack-protector-option.patch", which is included in the release. https://gitlab.gnome.org/GNOME/libdex/-/blob/0.8.0/NEWS Signed-off-by: Adrian Perez de Castro <aperez@igalia.com> --- .../0001-add-stack-protector-option.patch | 45 ------------------- package/libdex/libdex.hash | 4 +- package/libdex/libdex.mk | 5 ++- 3 files changed, 5 insertions(+), 49 deletions(-) delete mode 100644 package/libdex/0001-add-stack-protector-option.patch