diff mbox series

[1/1] package/espflash: bump v3.1.1

Message ID 20240919161908.125007-1-thomas.perale@mind.be
State New
Headers show
Series [1/1] package/espflash: bump v3.1.1 | expand

Commit Message

Thomas Perale Sept. 19, 2024, 4:19 p.m. UTC
Fix the following error:

error[E0282]: type annotations needed for `Box<_>`

The issue came from the `time` library depedency of espflash
(see https://github.com/time-rs/time/issues/693).
The `time` library has been bumped in the following commit
https://github.com/esp-rs/espflash/commit/233490736646ca7bc29463a98df98d7ccf53439d

Fixes:
  - https://autobuild.buildroot.org/results/321/321598baef543b84ce82c09a88e51ad745a15dfd/

Signed-off-by: Thomas Perale <thomas.perale@mind.be>
---
 package/espflash/espflash.hash | 2 +-
 package/espflash/espflash.mk   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/package/espflash/espflash.hash b/package/espflash/espflash.hash
index ebe24ef51f..0b1e160a47 100644
--- a/package/espflash/espflash.hash
+++ b/package/espflash/espflash.hash
@@ -1,4 +1,4 @@ 
 # Locally calculated
-sha256  8e5da5e90d03135a1b2af6c0b551e4f2504ad64e659b0e88e8a4ecd98cc6a6b6  espflash-3.1.0-cargo2.tar.gz
+sha256  f91a3e33e874bac0d7687d87c3cd692a54325c0dceaf35c983bd3d94519dee25  espflash-3.1.1-cargo2.tar.gz
 sha256  0886cf791a43c02d71c105b4835b53293704ec407a72f84a87f73e20cb2d3251  LICENSE-APACHE
 sha256  a75018ab59a13738ed2024a0090ae8f91b7693ae84568aa0e52c3dff99e6748d  LICENSE-MIT
diff --git a/package/espflash/espflash.mk b/package/espflash/espflash.mk
index ad2294e1bf..bcb343fc58 100644
--- a/package/espflash/espflash.mk
+++ b/package/espflash/espflash.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-ESPFLASH_VERSION = 3.1.0
+ESPFLASH_VERSION = 3.1.1
 ESPFLASH_SITE = $(call github,esp-rs,espflash,v$(ESPFLASH_VERSION))
 ESPFLASH_SUBDIR = espflash
 ESPFLASH_LICENSE = Apache-2.0 or MIT